summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorSven Ebenfeld <sven.ebenfeld@gmail.com>2016-01-22 23:11:43 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-01 15:51:15 +0100
commitabc0ec53987b67f07ab64ce4dbd0573cc3d4bd1b (patch)
treeb2cb11abbec350828e5a8607202f8559276a5447 /meta-python
parent8bebb8ef9c7a056902eef4f66aa85a15a7854014 (diff)
downloadmeta-openembedded-abc0ec53987b67f07ab64ce4dbd0573cc3d4bd1b.tar.gz
python-dateutil: 1.5 -> 2.4.2 and add python3 recipe
Signed-off-by: Sven Ebenfeld <sven.ebenfeld@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-dateutil.inc23
-rw-r--r--meta-python/recipes-devtools/python/python-dateutil_1.5.bb22
-rw-r--r--meta-python/recipes-devtools/python/python-dateutil_2.4.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-dateutil_2.4.2.bb2
4 files changed, 27 insertions, 22 deletions
diff --git a/meta-python/recipes-devtools/python/python-dateutil.inc b/meta-python/recipes-devtools/python/python-dateutil.inc
new file mode 100644
index 000000000..b38c44854
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-dateutil.inc
@@ -0,0 +1,23 @@
1SUMMARY = "Extensions to the standard Python datetime module"
2DESCRIPTION = "The dateutil module provides powerful extensions to the datetime module available in the Python standard library."
3HOMEPAGE = "https://dateutil.readthedocs.org"
4SECTION = "devel/python"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=51430b33c900f45f999c459ee29ca493"
7PR = "r0"
8
9SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10SRC_URI[md5sum] = "4ef68e1c485b09e9f034e10473e5add2"
11SRC_URI[sha256sum] = "3e95445c1db500a344079a47b171c45ef18f57d188dffdb0e4165c71bea8eb3d"
12
13SRCNAME = "python-dateutil"
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16PACKAGES =+ "${PN}-zoneinfo"
17FILES_${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo"
18
19RDEPENDS_${PN} = "\
20 ${PYTHON_PN}-core \
21 ${PYTHON_PN}-datetime \
22 ${PYTHON_PN}-six \
23 "
diff --git a/meta-python/recipes-devtools/python/python-dateutil_1.5.bb b/meta-python/recipes-devtools/python/python-dateutil_1.5.bb
deleted file mode 100644
index 37f19a839..000000000
--- a/meta-python/recipes-devtools/python/python-dateutil_1.5.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1SUMMARY = "Extensions to the standard Python date/time support"
2HOMEPAGE = "http://labix.org/python-dateutil"
3SECTION = "devel/python"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d82268718c68bda0b091006ec6e583c6"
6SRCNAME = "${BPN}"
7
8SRC_URI = "http://labix.org/download/python-dateutil/${SRCNAME}-${PV}.tar.gz"
9S = "${WORKDIR}/${SRCNAME}-${PV}"
10
11inherit setuptools
12
13PACKAGES =+ "${PN}-zoneinfo"
14FILES_${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo"
15
16RDEPENDS_${PN} = "\
17 python-core \
18 python-datetime \
19"
20
21SRC_URI[md5sum] = "35f3732db3f2cc4afdc68a8533b60a52"
22SRC_URI[sha256sum] = "c08aca7d85f8f8eed61e83b3423b829262c596a9a78f7ca3de0bcee2217d0e3b"
diff --git a/meta-python/recipes-devtools/python/python-dateutil_2.4.2.bb b/meta-python/recipes-devtools/python/python-dateutil_2.4.2.bb
new file mode 100644
index 000000000..12ae4c311
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-dateutil_2.4.2.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-dateutil.inc
diff --git a/meta-python/recipes-devtools/python/python3-dateutil_2.4.2.bb b/meta-python/recipes-devtools/python/python3-dateutil_2.4.2.bb
new file mode 100644
index 000000000..1d2baf55c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dateutil_2.4.2.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-dateutil.inc