summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorSven Ebenfeld <sven.ebenfeld@gmail.com>2016-01-22 23:22:50 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-01 15:51:15 +0100
commit816039cd96ba302477a7d784412873f28567f8f1 (patch)
tree30e32b081f793ef987c2df772e0fa3e600831c0a /meta-python
parentedae1715d7d0090672b32a5a2e484852764d6c57 (diff)
downloadmeta-openembedded-816039cd96ba302477a7d784412873f28567f8f1.tar.gz
python(3)-markupsafe: add recipes
Signed-off-by: Sven Ebenfeld <sven.ebenfeld@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-markupsafe.inc17
-rw-r--r--meta-python/recipes-devtools/python/python-markupsafe_0.23.bb19
-rw-r--r--meta-python/recipes-devtools/python/python3-markupsafe_0.23.bb2
3 files changed, 20 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-markupsafe.inc b/meta-python/recipes-devtools/python/python-markupsafe.inc
new file mode 100644
index 000000000..1b3e0a05c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-markupsafe.inc
@@ -0,0 +1,17 @@
1DESCRIPTION = "Implements a XML/HTML/XHTML Markup safe string for Python"
2HOMEPAGE = "http://github.com/mitsuhiko/markupsafe"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c6d1adcf45d69359f256c1cea3254127"
6
7PR = "r0"
8SRCNAME = "MarkupSafe"
9
10SRC_URI = "https://pypi.python.org/packages/source/M/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "f5ab3deee4c37cd6a922fb81e730da6e"
13SRC_URI[sha256sum] = "a4ec1aff59b95a14b45eb2e23761a0179e98319da5a7eb76b56ea8cdc7b871c3"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17RDEPENDS_${PN} += "${PYTHON_PN}-re"
diff --git a/meta-python/recipes-devtools/python/python-markupsafe_0.23.bb b/meta-python/recipes-devtools/python/python-markupsafe_0.23.bb
index 4821c0a3b..396eff102 100644
--- a/meta-python/recipes-devtools/python/python-markupsafe_0.23.bb
+++ b/meta-python/recipes-devtools/python/python-markupsafe_0.23.bb
@@ -1,19 +1,2 @@
1DESCRIPTION = "Implements a XML/HTML/XHTML Markup safe string for Python"
2HOMEPAGE = "http://github.com/mitsuhiko/markupsafe"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c6d1adcf45d69359f256c1cea3254127"
6
7PR = "r0"
8SRCNAME = "MarkupSafe"
9
10SRC_URI = "https://pypi.python.org/packages/source/M/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "f5ab3deee4c37cd6a922fb81e730da6e"
13SRC_URI[sha256sum] = "a4ec1aff59b95a14b45eb2e23761a0179e98319da5a7eb76b56ea8cdc7b871c3"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools 1inherit setuptools
18 2require python-markupsafe.inc
19RDEPENDS_${PN} += "python-re"
diff --git a/meta-python/recipes-devtools/python/python3-markupsafe_0.23.bb b/meta-python/recipes-devtools/python/python3-markupsafe_0.23.bb
new file mode 100644
index 000000000..765e3c906
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-markupsafe_0.23.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-markupsafe.inc