summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-02 21:58:31 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-12 06:56:44 +0200
commit7ef21540318bd890646dc33f89ff01f76d4c55c7 (patch)
treea8aa8920a6b0fddc2774af086ddb4efc5fc9912c /meta-python
parent4de601006dddbf50501aeaae7f53d2497964a082 (diff)
downloadmeta-openembedded-7ef21540318bd890646dc33f89ff01f76d4c55c7.tar.gz
python-numeric: Fix build with musl
Use gettimeofday() definition from system Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch30
-rw-r--r--meta-python/recipes-devtools/python/python-numeric_24.2.bb4
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch b/meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch
new file mode 100644
index 000000000..81ed744cb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch
@@ -0,0 +1,30 @@
1From 322e781c67d7a78fc2cfc3d377f50b825fc64abb Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 2 Jun 2017 20:21:01 -0700
4Subject: [PATCH] it tries to define this function differently than it is
5 defined in sys/time.h.
6
7Use the definition from system
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 Packages/RNG/Src/ranf.c | 3 ---
12 1 file changed, 3 deletions(-)
13
14diff --git a/Packages/RNG/Src/ranf.c b/Packages/RNG/Src/ranf.c
15index 5ca7dc5..e669fa8 100644
16--- a/Packages/RNG/Src/ranf.c
17+++ b/Packages/RNG/Src/ranf.c
18@@ -149,9 +149,6 @@ void Mixranf(int *s,u32 s48[2])
19 #else
20 struct timeval tv;
21 struct timezone tz;
22-#if !defined(__sgi)
23- int gettimeofday(struct timeval *, struct timezone *);
24-#endif
25
26 (void)gettimeofday(&tv,&tz);
27 s48[0] = (u32)tv.tv_sec;
28--
292.13.0
30
diff --git a/meta-python/recipes-devtools/python/python-numeric_24.2.bb b/meta-python/recipes-devtools/python/python-numeric_24.2.bb
index c0b04e144..c91d77c81 100644
--- a/meta-python/recipes-devtools/python/python-numeric_24.2.bb
+++ b/meta-python/recipes-devtools/python/python-numeric_24.2.bb
@@ -5,7 +5,9 @@ LIC_FILES_CHKSUM = "file://Legal.htm;md5=e3ce75dedd4043918d15979ae43e312e"
5 5
6PR = "ml3" 6PR = "ml3"
7 7
8SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/Numeric-${PV}.tar.gz" 8SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/Numeric-${PV}.tar.gz \
9 file://0001-it-tries-to-define-this-function-differently-than-it.patch \
10"
9S = "${WORKDIR}/Numeric-${PV}" 11S = "${WORKDIR}/Numeric-${PV}"
10 12
11inherit distutils 13inherit distutils