summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorGuy Morand <guy@guy-morand.ch>2017-10-03 11:10:47 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-04 14:53:32 +0000
commit398efac6009f03735bf2347770033c04ea784b6a (patch)
tree59d7c8d4482d56e5787c24627a95be97c5aac590 /meta-python
parenta43751b149e1517ee59b0d7ea7484510f6ab420e (diff)
downloadmeta-openembedded-398efac6009f03735bf2347770033c04ea784b6a.tar.gz
Add python pandas recipes
Signed-off-by: Guy Morand <guy@guy-morand.ch> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pandas.inc23
-rw-r--r--meta-python/recipes-devtools/python/python-pandas_0.20.3.bb7
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_0.20.3.bb2
3 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pandas.inc b/meta-python/recipes-devtools/python/python-pandas.inc
new file mode 100644
index 000000000..d1f3707a5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pandas.inc
@@ -0,0 +1,23 @@
1SUMMARY = "pandas library for high-performance data analysis tools"
2DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
3high-performance, easy-to-use data structures and data analysis tools for \
4the Python programming language."
5HOMEPAGE = "http://pandas.pydata.org/"
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=66017d3134349017409386be85176145"
8
9SRC_URI[md5sum] = "4df858f28b4bf4fa07d9fbb7f2568173"
10SRC_URI[sha256sum] = "a777e07633d83d546c55706420179551c8e01075b53c497dcf8ae4036766bc66"
11
12PYPI_PACKAGE = "pandas"
13inherit pypi
14
15DEPENDS += " \
16 ${PYTHON_PN}-numpy-native \
17"
18
19RDEPENDS_${PN} += " \
20 ${PYTHON_PN}-numpy \
21 ${PYTHON_PN}-dateutil \
22 ${PYTHON_PN}-pytz \
23"
diff --git a/meta-python/recipes-devtools/python/python-pandas_0.20.3.bb b/meta-python/recipes-devtools/python/python-pandas_0.20.3.bb
new file mode 100644
index 000000000..20973c8e8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pandas_0.20.3.bb
@@ -0,0 +1,7 @@
1inherit setuptools
2require python-pandas.inc
3
4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-json \
6 ${PYTHON_PN}-importlib \
7"
diff --git a/meta-python/recipes-devtools/python/python3-pandas_0.20.3.bb b/meta-python/recipes-devtools/python/python3-pandas_0.20.3.bb
new file mode 100644
index 000000000..b5dd5e092
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pandas_0.20.3.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-pandas.inc