summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-04-21 17:08:17 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-26 20:13:28 +0200
commitf420757d1c31dc2c752321e7589357d25d6ce9d8 (patch)
treef56a3aa48b1ca9a33dabb31a623cf9027240fa8b /meta-python
parent65525a2d74604a122cf149c206c843c478118219 (diff)
downloadmeta-openembedded-f420757d1c31dc2c752321e7589357d25d6ce9d8.tar.gz
python-snimpy: add new recipe
Snimpy is a Python-based tool providing a simple interface to build SNMP query. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-snimpy_0.8.11.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-snimpy_0.8.11.bb b/meta-python/recipes-devtools/python/python-snimpy_0.8.11.bb
new file mode 100644
index 000000000..cbdc6bd86
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-snimpy_0.8.11.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Interactive SNMP tool"
2DESCRIPTION = "Snimpy is a Python-based tool providing a simple interface to build SNMP query"
3HOMEPAGE = "https://pypi.python.org/pypi/snimpy"
4SECTION = "devel/python"
5
6DEPENDS = "libsmi python-cffi-native python-vcversioner-native"
7
8LICENSE = "ISC"
9LIC_FILES_CHKSUM = "file://docs/license.rst;md5=7c53ab2d1240828625c3e093d049d4f4"
10
11SRCNAME = "snimpy"
12
13SRC_URI = "https://files.pythonhosted.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "7f6270ce2e7206df165602e66d5ceb96"
16SRC_URI[sha256sum] = "10410614c7bff1053ca65bd760ce919f1a074f4988b857df4c57cf35847922b0"
17
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit setuptools
21
22RDEPENDS_${PN} = "python-cffi \
23 python-pycparser \
24 python-pysnmp \
25 python-setuptools \
26"