summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-12-02 19:04:16 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-13 11:19:11 +0100
commitc0c8f946c1354a6be7685a14cb34e940ebd15af5 (patch)
tree31a84400a1ac5aa4ca587fb3f595f7b189ca5a90 /meta-python
parenta14aa989b93f86712d3440728eee650d2fa8fdf0 (diff)
downloadmeta-openembedded-c0c8f946c1354a6be7685a14cb34e940ebd15af5.tar.gz
python-cson: Add recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-extended/python-cson/python-cson_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-cson/python-cson_git.bb b/meta-python/recipes-extended/python-cson/python-cson_git.bb
new file mode 100644
index 000000000..efb338cf2
--- /dev/null
+++ b/meta-python/recipes-extended/python-cson/python-cson_git.bb
@@ -0,0 +1,21 @@
1# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Python library for CSON (schema-compressed JSON)"
5HOMEPAGE = "https://github.com/gt3389b/python-cson/"
6LICENSE = "MIT"
7SECTION = "devel/python"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=7709d2635e63ab96973055a23c2a4cac"
9
10SRCREV = "f3f2898c44bb16b951d3e9f2fbf6d1c4158edda2"
11SRC_URI = "git://github.com/gt3389b/python-cson.git"
12
13S = "${WORKDIR}/git"
14
15RDEPENDS_${PN}_class-native = ""
16DEPENDS_append_class-native = " python-native "
17
18inherit setuptools
19
20BBCLASSEXTEND = "native"
21