summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-03-02 22:17:17 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-07 13:29:46 +0100
commit5962ec478c69e3dcd9c5fbfffb609ffe921279c8 (patch)
tree42ec2844a4a0603edcff6d2a48743e77ee460a54 /meta-python
parentd911e0f5f15b21fb50a50cfc7ba4873321d7c957 (diff)
downloadmeta-openembedded-5962ec478c69e3dcd9c5fbfffb609ffe921279c8.tar.gz
python-dnspython: add initial recipe with version 1.15.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-dnspython.inc20
-rw-r--r--meta-python/recipes-devtools/python/python-dnspython_1.15.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb9
3 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-dnspython.inc b/meta-python/recipes-devtools/python/python-dnspython.inc
new file mode 100644
index 000000000..6a04429b7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-dnspython.inc
@@ -0,0 +1,20 @@
1DESCRIPTION = "DNS toolkit for Python"
2HOMEPAGE = "http://www.dnspython.org/"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b9d855ee0d7bea17c8b0994d37985e1e"
5
6SRC_URI[md5sum] = "05d33ffb5d8f35ae0474bb952778a344"
7SRC_URI[sha256sum] = "40f563e1f7a7b80dc5a4e76ad75c23da53d62f1e15e6e517293b04e1f84ead7c"
8
9PYPI_PACKAGE_EXT = "zip"
10
11inherit pypi
12
13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-crypt \
15 ${PYTHON_PN}-io \
16 ${PYTHON_PN}-math \
17 ${PYTHON_PN}-netclient \
18 ${PYTHON_PN}-numbers \
19 ${PYTHON_PN}-threading \
20"
diff --git a/meta-python/recipes-devtools/python/python-dnspython_1.15.0.bb b/meta-python/recipes-devtools/python/python-dnspython_1.15.0.bb
new file mode 100644
index 000000000..9dbcd0ffb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-dnspython_1.15.0.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-dnspython.inc
diff --git a/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb b/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
new file mode 100644
index 000000000..26024c68f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
@@ -0,0 +1,9 @@
1inherit setuptools3
2require python-dnspython.inc
3
4# Requires _pydecimal.py which is in misc
5RDEPENDS_${PN} += " \
6 ${PYTHON_PN}-enum \
7 ${PYTHON_PN}-misc \
8 ${PYTHON_PN}-selectors \
9"