summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-03-08 08:16:03 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-11 17:56:45 +0100
commit5831b3680c4b57e229fc4dda71a0ee5b42ae8672 (patch)
tree64b460c2eb37618cde3867fe6e647bf336f95994 /meta-python
parent1d4249389a656dfd13cf51224d46037a3d60fda8 (diff)
downloadmeta-openembedded-5831b3680c4b57e229fc4dda71a0ee5b42ae8672.tar.gz
python-serpent: add a python3 recipe
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-serpent.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-serpent_1.18.1.bb15
-rw-r--r--meta-python/recipes-devtools/python/python3-serpent_1.18.1.bb8
3 files changed, 23 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python-serpent.inc b/meta-python/recipes-devtools/python/python-serpent.inc
new file mode 100644
index 000000000..a1520db49
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-serpent.inc
@@ -0,0 +1,13 @@
1SUMMARY = "Serialization based on ast.literal_eval"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=2669deccb79531c74a5ddd71b45f5095"
4
5SRC_URI[md5sum] = "e2cd7b751274c59b420d4f54db9a49cf"
6SRC_URI[sha256sum] = "9afebb58ac8b827050e1969324388349dc9738b0a03b0d91567b328834a27732"
7
8inherit pypi
9
10RDEPENDS_${PN} += "\
11 ${PYTHON_PN}-netclient \
12 ${PYTHON_PN}-numbers \
13 "
diff --git a/meta-python/recipes-devtools/python/python-serpent_1.18.1.bb b/meta-python/recipes-devtools/python/python-serpent_1.18.1.bb
index f18343ab5..0db3cf98a 100644
--- a/meta-python/recipes-devtools/python/python-serpent_1.18.1.bb
+++ b/meta-python/recipes-devtools/python/python-serpent_1.18.1.bb
@@ -1,13 +1,2 @@
1SUMMARY = "Serialization based on ast.literal_eval" 1inherit setuptools
2LICENSE = "MIT" 2require python-serpent.inc
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=2669deccb79531c74a5ddd71b45f5095"
4
5SRC_URI[md5sum] = "e2cd7b751274c59b420d4f54db9a49cf"
6SRC_URI[sha256sum] = "9afebb58ac8b827050e1969324388349dc9738b0a03b0d91567b328834a27732"
7
8inherit pypi setuptools
9
10RDEPENDS_${PN} += "\
11 ${PYTHON_PN}-netclient \
12 ${PYTHON_PN}-numbers \
13 "
diff --git a/meta-python/recipes-devtools/python/python3-serpent_1.18.1.bb b/meta-python/recipes-devtools/python/python3-serpent_1.18.1.bb
new file mode 100644
index 000000000..199dcfafd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-serpent_1.18.1.bb
@@ -0,0 +1,8 @@
1inherit setuptools3
2require python-serpent.inc
3
4# Requires _pydecimal which is in misc
5RDEPENDS_${PN} += " \
6 ${PYTHON_PN}-enum \
7 ${PYTHON_PN}-misc \
8"