diff options
author | Mikko Ylinen <mikko.ylinen@linux.intel.com> | 2016-08-30 09:55:44 +0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-09-05 13:30:52 +0200 |
commit | 2cdd3d645671a459319caa2d016dd1af6ebe204a (patch) | |
tree | 4e1e85f7a0213a47884b365eca77538faa58efec /meta-python | |
parent | 2fe1b297615b6ce526870fbf1902c3d0541c26c1 (diff) | |
download | meta-openembedded-2cdd3d645671a459319caa2d016dd1af6ebe204a.tar.gz |
python3-vcversioner: add recipe
python3-vcversioner is needed by other python3 modules so it's good to have
a recipe for it.
Signed-off-by: Mikko Ylinen <mikko.ylinen@linux.intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb b/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb new file mode 100644 index 000000000..189a65a98 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | SUMMARY = "Python vcversioner, automagically update the project's version" | ||
2 | HOMEPAGE = "https://github.com/habnabit/vcversioner" | ||
3 | |||
4 | LICENSE = "ISC" | ||
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=827a7a91a8d20d3c666b665cd96db8e3" | ||
6 | |||
7 | SRC_URI[md5sum] = "aab6ef5e0cf8614a1b1140ed5b7f107d" | ||
8 | SRC_URI[sha256sum] = "dae60c17a479781f44a4010701833f1829140b1eeccd258762a74974aa06e19b" | ||
9 | |||
10 | inherit pypi setuptools3 | ||
11 | |||
12 | do_compile_append() { | ||
13 | ${PYTHON} setup.py -q bdist_egg --dist-dir ./ | ||
14 | } | ||
15 | |||
16 | do_install_append() { | ||
17 | install -m 0644 ${S}/vcversioner*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/ | ||
18 | } | ||
19 | |||
20 | RDEPENDS_${PN} += "\ | ||
21 | ${PYTHON_PN}-subprocess \ | ||
22 | " | ||
23 | |||
24 | BBCLASSEXTEND = "native" | ||