summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2015-08-31 16:08:24 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-08 16:25:21 +0200
commit2315f412f625a85e683cf294356b651dcd05a029 (patch)
treef14b803e5324c544a8085b08ef2f2d5167cbba16 /meta-python
parent675a49ef0a6b76fd652e4b57ccbbe8b1e1085ec6 (diff)
downloadmeta-openembedded-2315f412f625a85e683cf294356b651dcd05a029.tar.gz
python-pyroute2: Add recipe
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch26
-rw-r--r--meta-python/recipes-devtools/python/python-pyroute2_0.3.12.bb14
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch b/meta-python/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch
new file mode 100644
index 000000000..d73da07d2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch
@@ -0,0 +1,26 @@
1Upstream-Status: Inappropriate [wrong dependency]
2
3Subject: [PATCH] import simplejson as json
4
5At runtime python-pyroute2 tries to import json, but the module is not
6available, import simplejson as json solve the issue.
7
8Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
9---
10 pyroute2/netlink/rtnl/ifinfmsg.py | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/pyroute2/netlink/rtnl/ifinfmsg.py b/pyroute2/netlink/rtnl/ifinfmsg.py
14index 4f14f25..55643eb 100644
15--- a/pyroute2/netlink/rtnl/ifinfmsg.py
16+++ b/pyroute2/netlink/rtnl/ifinfmsg.py
17@@ -1,5 +1,5 @@
18 import os
19-import json
20+import simplejson as json
21 import errno
22 import select
23 import struct
24--
252.1.4
26
diff --git a/meta-python/recipes-devtools/python/python-pyroute2_0.3.12.bb b/meta-python/recipes-devtools/python/python-pyroute2_0.3.12.bb
new file mode 100644
index 000000000..d809d9718
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyroute2_0.3.12.bb
@@ -0,0 +1,14 @@
1DESCRIPTION = "A pure Python netlink and Linux network configuration library"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=270323035ef766597dabd91747c36e3d"
4
5SRC_URI[md5sum] = "5d83ec82acb54ab88c98f0d25d13308b"
6SRC_URI[sha256sum] = "c0e1637a75e099104f14d9e03fd5a698dfcc923a22fbfac4a19bd7e94d1fcaa5"
7
8SRC_URI += "file://import-simplejson-as-json.patch"
9
10inherit pypi
11
12RDEPENDS_${PN} = "python-distutils \
13 python-simplejson \
14 "