summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-03-09 08:33:08 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-11 17:57:05 +0100
commit1a373a033f482981eb59ff8d9eb7a9437fa18cd4 (patch)
treecce261800b769e73a7a1b47eaed5398ed5467973 /meta-python
parenta4a1950e36a86bcc3e60fffdb0bbe5bc98d9daf0 (diff)
downloadmeta-openembedded-1a373a033f482981eb59ff8d9eb7a9437fa18cd4.tar.gz
python-pyparsing: update to version 2.2.0
Fix the RDEPENDS and add a python3 version as well Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyparsing.inc19
-rw-r--r--meta-python/recipes-devtools/python/python-pyparsing_2.1.10.bb9
-rw-r--r--meta-python/recipes-devtools/python/python-pyparsing_2.2.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyparsing_2.2.0.bb2
4 files changed, 23 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyparsing.inc b/meta-python/recipes-devtools/python/python-pyparsing.inc
new file mode 100644
index 000000000..033e0dbc0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyparsing.inc
@@ -0,0 +1,19 @@
1SUMMARY = "Python parsing module"
2HOMEPAGE = "http://pyparsing.wikispaces.com/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=fb46329938e6bc829b256e37d5c1e31a"
5
6SRC_URI[md5sum] = "0214e42d63af850256962b6744c948d9"
7SRC_URI[sha256sum] = "0832bcf47acd283788593e7a0f542407bd9550a55a8a8435214a1960e04bcb04"
8
9inherit pypi
10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-debugger \
14 ${PYTHON_PN}-json \
15 ${PYTHON_PN}-netclient \
16 ${PYTHON_PN}-pprint \
17 ${PYTHON_PN}-stringold \
18 ${PYTHON_PN}-threading \
19"
diff --git a/meta-python/recipes-devtools/python/python-pyparsing_2.1.10.bb b/meta-python/recipes-devtools/python/python-pyparsing_2.1.10.bb
deleted file mode 100644
index 06f98457c..000000000
--- a/meta-python/recipes-devtools/python/python-pyparsing_2.1.10.bb
+++ /dev/null
@@ -1,9 +0,0 @@
1SUMMARY = "Python parsing module"
2HOMEPAGE = "http://pyparsing.wikispaces.com/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=fb46329938e6bc829b256e37d5c1e31a"
5
6SRC_URI[md5sum] = "065908b92904e0d3634eb156f44cc80e"
7SRC_URI[sha256sum] = "811c3e7b0031021137fc83e051795025fcb98674d07eb8fe922ba4de53d39188"
8
9inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python-pyparsing_2.2.0.bb b/meta-python/recipes-devtools/python/python-pyparsing_2.2.0.bb
new file mode 100644
index 000000000..90217f3c3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyparsing_2.2.0.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-pyparsing.inc
diff --git a/meta-python/recipes-devtools/python/python3-pyparsing_2.2.0.bb b/meta-python/recipes-devtools/python/python3-pyparsing_2.2.0.bb
new file mode 100644
index 000000000..0805fee3e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyparsing_2.2.0.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-pyparsing.inc