summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@minotaurinc.com>2014-11-10 18:19:08 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-11-24 11:59:48 +0100
commit5f6760e59a2df208dddb04e8e45b10a15aa99d2c (patch)
tree12fadb9aa2b6a7195f2338321a3d7ce2e28b746f /meta-python
parente0570eaccc6968b8c52ff12fa47781f5141ef1ec (diff)
downloadmeta-openembedded-5f6760e59a2df208dddb04e8e45b10a15aa99d2c.tar.gz
python-flufl-enum: add recipe for 4.0.1
Signed-off-by: Derek Straka <derek@minotaurinc.com> Acked-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-flufl-enum_4.0.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-flufl-enum_4.0.1.bb b/meta-python/recipes-devtools/python/python-flufl-enum_4.0.1.bb
new file mode 100644
index 000000000..a7376db5d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flufl-enum_4.0.1.bb
@@ -0,0 +1,33 @@
1SUMMARY = "A Python enumeration package."
2DESCRIPTION = "The flufl.enum library is a Python enumeration package. Its goal is to provide simple, \
3specific, concise semantics in an easy to read and write syntax. flufl.enum has just enough of the \
4features needed to make enumerations useful, but without a lot of extra baggage to weigh them down. "
5HOMEPAGE = "https://pypi.python.org/pypi/flufl.enum"
6SECTION = "devel/python"
7
8LICENSE = "LGPLv3"
9LIC_FILES_CHKSUM = "file://PKG-INFO;md5=1fa25baed15d3be23c902636379438e8"
10
11SRCNAME = "flufl.enum"
12
13SRC_URI = " \
14 http://pypi.python.org/packages/source/f/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
15"
16
17SRC_URI[md5sum] = "b3ad23761a78232bc78499ced7cb85d9"
18SRC_URI[sha256sum] = "4af7e7cf2dcc7517251570c7ef9ad194e30ee4b6f860eba500c03954ae95f9d8"
19
20inherit setuptools
21
22S = "${WORKDIR}/${SRCNAME}-${PV}"
23
24PACKAGES =+ "\
25 ${PN}-test \
26"
27
28FILES_${PN}-doc += "\
29 ${libdir}/${PYTHON_DIR}/site-packages/flufl/enum/*.rst \
30 ${libdir}/${PYTHON_DIR}/site-packages/flufl/enum/docs \
31"
32
33FILES_${PN}-test += "${libdir}/${PYTHON_DIR}/site-packages/flufl/enum/tests"