summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2020-06-16 01:28:35 +0800
committerKhem Raj <raj.khem@gmail.com>2020-06-17 08:57:49 -0700
commitfff5e10eb501fdb957c5e2b5301c7fed0ed813f4 (patch)
tree8a752ce78f2e356b3da27bb2e698388339c32373 /meta-python
parent8ee8d72df4a18c3afb5fcf3089d85bc2741a8234 (diff)
downloadmeta-openembedded-fff5e10eb501fdb957c5e2b5301c7fed0ed813f4.tar.gz
python3-cachetools: Enable ptest
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-cachetools/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-cachetools_4.1.0.bb15
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cachetools/run-ptest b/meta-python/recipes-devtools/python/python3-cachetools/run-ptest
new file mode 100644
index 000000000..b63c4de0d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cachetools/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-cachetools_4.1.0.bb b/meta-python/recipes-devtools/python/python3-cachetools_4.1.0.bb
index 7411a749d..07d86cfc5 100644
--- a/meta-python/recipes-devtools/python/python3-cachetools_4.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-cachetools_4.1.0.bb
@@ -8,7 +8,20 @@ SECTION = "devel/python"
8LICENSE = "MIT" 8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=2d1e1bf0ccb26126a230c51f997ce362" 9LIC_FILES_CHKSUM = "file://LICENSE;md5=2d1e1bf0ccb26126a230c51f997ce362"
10 10
11inherit pypi setuptools3 11inherit pypi setuptools3 ptest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS_${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
12 25
13SRC_URI[md5sum] = "4468da43443115a00c02c126cf601ae0" 26SRC_URI[md5sum] = "4468da43443115a00c02c126cf601ae0"
14SRC_URI[sha256sum] = "1d057645db16ca7fe1f3bd953558897603d6f0b9c51ed9d11eb4d071ec4e2aab" 27SRC_URI[sha256sum] = "1d057645db16ca7fe1f3bd953558897603d6f0b9c51ed9d11eb4d071ec4e2aab"