diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2019-02-15 01:04:48 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-02-17 12:21:27 -0800 |
commit | f6a3e4b5632460e66c5f8105d1c51e49c68a5b8d (patch) | |
tree | b35e9608c009258666241d84769f490cf3c2a597 /meta-python | |
parent | 19dee696a2c246c503ec41c2ff8808cc3cd127ce (diff) | |
download | meta-openembedded-f6a3e4b5632460e66c5f8105d1c51e49c68a5b8d.tar.gz |
python3-h5py: add version 2.9.0
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch | 46 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb | 30 |
2 files changed, 76 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch new file mode 100644 index 000000000..ff50c85a0 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch | |||
@@ -0,0 +1,46 @@ | |||
1 | From 7e3b1745c1fef34683a0610381dd3308ad4d1ba9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Tue, 29 Jan 2019 17:08:32 +0800 | ||
4 | Subject: [PATCH] cross compiling support | ||
5 | |||
6 | Remove useless dirs | ||
7 | |||
8 | Upstream-Status: Inappropriate [oe specific] | ||
9 | |||
10 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
11 | --- | ||
12 | setup_build.py | 4 ---- | ||
13 | setup_configure.py | 2 +- | ||
14 | 2 files changed, 1 insertion(+), 5 deletions(-) | ||
15 | |||
16 | diff --git a/setup_build.py b/setup_build.py | ||
17 | index 85b321a..2c78e92 100644 | ||
18 | --- a/setup_build.py | ||
19 | +++ b/setup_build.py | ||
20 | @@ -53,10 +53,6 @@ if sys.platform.startswith('win'): | ||
21 | ('_HDF5USEDLL_', None), | ||
22 | ('H5_BUILT_AS_DYNAMIC_LIB', None) | ||
23 | ]) | ||
24 | -else: | ||
25 | - FALLBACK_PATHS['include_dirs'].extend(['/opt/local/include', '/usr/local/include']) | ||
26 | - FALLBACK_PATHS['library_dirs'].extend(['/opt/local/lib', '/usr/local/lib']) | ||
27 | - | ||
28 | |||
29 | class h5py_build_ext(build_ext): | ||
30 | |||
31 | diff --git a/setup_configure.py b/setup_configure.py | ||
32 | index a2de76a..197f2da 100644 | ||
33 | --- a/setup_configure.py | ||
34 | +++ b/setup_configure.py | ||
35 | @@ -208,7 +208,7 @@ def autodetect_version(hdf5_dir=None): | ||
36 | else: | ||
37 | regexp = re.compile(r'^libhdf5.so') | ||
38 | |||
39 | - libdirs = ['/usr/local/lib', '/opt/local/lib'] | ||
40 | + libdirs = [] | ||
41 | try: | ||
42 | if pkgconfig.exists("hdf5"): | ||
43 | libdirs.extend(pkgconfig.parse("hdf5")['library_dirs']) | ||
44 | -- | ||
45 | 2.7.4 | ||
46 | |||
diff --git a/meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb b/meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb new file mode 100644 index 000000000..bca7757ad --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python. " | ||
2 | HOMEPAGE = "https://www.h5py.org/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://setup.py;beginline=107;endline=107;md5=795ecad0d261c998cc526c84a822dff6" | ||
6 | |||
7 | SRC_URI = "git://github.com/h5py/h5py.git \ | ||
8 | file://0001-cross-compiling-support.patch \ | ||
9 | " | ||
10 | SRCREV ?= "8d96a14c3508de1bde77aec5db302e478dc5dbc4" | ||
11 | |||
12 | inherit setuptools3 | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | BBCLASSEXTEND = "native" | ||
17 | |||
18 | DEPENDS = "python3-pkgconfig-native \ | ||
19 | python3-cython-native \ | ||
20 | python3-numpy-native \ | ||
21 | python3-six-native \ | ||
22 | python3 \ | ||
23 | hdf5 \ | ||
24 | " | ||
25 | |||
26 | RDEPENDS_${PN} = "python3-numpy \ | ||
27 | python3-six \ | ||
28 | " | ||
29 | |||
30 | export HDF5_VERSION="1.8.19" | ||