diff options
author | Trevor Gamblin <trevor.gamblin@windriver.com> | 2021-06-07 11:28:30 -0400 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-06-09 08:45:24 -0700 |
commit | f3426371315ef7e19bed4347b2f071e02888dd98 (patch) | |
tree | f01468157630a542d7e8fc3a4c761b3f6d94cb7e /meta-python | |
parent | cf6014d1b5f75a74bde221a5c9a39152c40433c2 (diff) | |
download | meta-openembedded-f3426371315ef7e19bed4347b2f071e02888dd98.tar.gz |
python3-yappi: fix ptests
- Add a patch to fix imports in unit tests
- Add python3-gevent and python3-zopeinterface to ptest RDEPENDS
- Sort ptest RDEPENDS alphabetically
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-yappi/0001-Fix-imports-for-ptests.patch | 96 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb | 5 |
2 files changed, 100 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yappi/0001-Fix-imports-for-ptests.patch b/meta-python/recipes-devtools/python/python3-yappi/0001-Fix-imports-for-ptests.patch new file mode 100644 index 000000000..714b2a2d3 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-yappi/0001-Fix-imports-for-ptests.patch | |||
@@ -0,0 +1,96 @@ | |||
1 | From 0dedc1c573ddc4e87475eb03c64555cd54a72e92 Mon Sep 17 00:00:00 2001 | ||
2 | From: Trevor Gamblin <trevor.gamblin@windriver.com> | ||
3 | Date: Mon, 7 Jun 2021 09:40:20 -0400 | ||
4 | Subject: [PATCH] Fix imports for tests | ||
5 | |||
6 | Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> | ||
7 | --- | ||
8 | tests/test_asyncio.py | 2 +- | ||
9 | tests/test_asyncio_context_vars.py | 2 +- | ||
10 | tests/test_functionality.py | 2 +- | ||
11 | tests/test_gevent.py | 2 +- | ||
12 | tests/test_hooks.py | 2 +- | ||
13 | tests/test_tags.py | 2 +- | ||
14 | 6 files changed, 6 insertions(+), 6 deletions(-) | ||
15 | |||
16 | diff --git a/tests/test_asyncio.py b/tests/test_asyncio.py | ||
17 | index 4ac4c5f..4de94cf 100644 | ||
18 | --- a/tests/test_asyncio.py | ||
19 | +++ b/tests/test_asyncio.py | ||
20 | @@ -2,7 +2,7 @@ import unittest | ||
21 | import yappi | ||
22 | import asyncio | ||
23 | import threading | ||
24 | -from utils import YappiUnitTestCase, find_stat_by_name, burn_cpu, burn_io | ||
25 | +from .utils import YappiUnitTestCase, find_stat_by_name, burn_cpu, burn_io | ||
26 | |||
27 | |||
28 | @asyncio.coroutine | ||
29 | diff --git a/tests/test_asyncio_context_vars.py b/tests/test_asyncio_context_vars.py | ||
30 | index 5bd750c..9a253c0 100644 | ||
31 | --- a/tests/test_asyncio_context_vars.py | ||
32 | +++ b/tests/test_asyncio_context_vars.py | ||
33 | @@ -5,7 +5,7 @@ import contextvars | ||
34 | import functools | ||
35 | import time | ||
36 | import os | ||
37 | -import utils | ||
38 | +import tests.utils as utils | ||
39 | import yappi | ||
40 | |||
41 | async_context_id = contextvars.ContextVar('async_context_id') | ||
42 | diff --git a/tests/test_functionality.py b/tests/test_functionality.py | ||
43 | index a73cb63..2ab273f 100644 | ||
44 | --- a/tests/test_functionality.py | ||
45 | +++ b/tests/test_functionality.py | ||
46 | @@ -5,7 +5,7 @@ import threading | ||
47 | import unittest | ||
48 | import yappi | ||
49 | import _yappi | ||
50 | -import utils | ||
51 | +import tests.utils as utils | ||
52 | import multiprocessing # added to fix http://bugs.python.org/issue15881 for > Py2.6 | ||
53 | import subprocess | ||
54 | |||
55 | diff --git a/tests/test_gevent.py b/tests/test_gevent.py | ||
56 | index 8569712..fe15b29 100644 | ||
57 | --- a/tests/test_gevent.py | ||
58 | +++ b/tests/test_gevent.py | ||
59 | @@ -4,7 +4,7 @@ import yappi | ||
60 | import gevent | ||
61 | from gevent.event import Event | ||
62 | import threading | ||
63 | -from utils import ( | ||
64 | +from .utils import ( | ||
65 | YappiUnitTestCase, find_stat_by_name, burn_cpu, burn_io, | ||
66 | burn_io_gevent | ||
67 | ) | ||
68 | diff --git a/tests/test_hooks.py b/tests/test_hooks.py | ||
69 | index a96a4f1..e4177ba 100644 | ||
70 | --- a/tests/test_hooks.py | ||
71 | +++ b/tests/test_hooks.py | ||
72 | @@ -5,7 +5,7 @@ import unittest | ||
73 | import time | ||
74 | |||
75 | import yappi | ||
76 | -import utils | ||
77 | +import tests.utils as utils | ||
78 | |||
79 | |||
80 | def a(): | ||
81 | diff --git a/tests/test_tags.py b/tests/test_tags.py | ||
82 | index b0b531d..1928888 100644 | ||
83 | --- a/tests/test_tags.py | ||
84 | +++ b/tests/test_tags.py | ||
85 | @@ -2,7 +2,7 @@ import unittest | ||
86 | import yappi | ||
87 | import threading | ||
88 | import time | ||
89 | -from utils import YappiUnitTestCase, find_stat_by_name, burn_cpu, burn_io | ||
90 | +from .utils import YappiUnitTestCase, find_stat_by_name, burn_cpu, burn_io | ||
91 | |||
92 | |||
93 | class MultiThreadTests(YappiUnitTestCase): | ||
94 | -- | ||
95 | 2.31.1 | ||
96 | |||
diff --git a/meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb b/meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb index 7c3f0fd4b..8a1aca21f 100644 --- a/meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb +++ b/meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb | |||
@@ -8,6 +8,7 @@ SRC_URI[sha256sum] = "a51d3e6e5563cc74b5bb82ed6e7bd44a9c1a7eae3d97e4d52e9465edb3 | |||
8 | 8 | ||
9 | SRC_URI += " \ | 9 | SRC_URI += " \ |
10 | file://run-ptest \ | 10 | file://run-ptest \ |
11 | file://0001-Fix-imports-for-ptests.patch \ | ||
11 | " | 12 | " |
12 | 13 | ||
13 | inherit pypi setuptools3 ptest | 14 | inherit pypi setuptools3 ptest |
@@ -19,9 +20,11 @@ RDEPENDS_${PN} += "\ | |||
19 | " | 20 | " |
20 | 21 | ||
21 | RDEPENDS_${PN}-ptest += " \ | 22 | RDEPENDS_${PN}-ptest += " \ |
22 | ${PYTHON_PN}-pytest \ | 23 | ${PYTHON_PN}-gevent \ |
23 | ${PYTHON_PN}-multiprocessing \ | 24 | ${PYTHON_PN}-multiprocessing \ |
25 | ${PYTHON_PN}-pytest \ | ||
24 | ${PYTHON_PN}-profile \ | 26 | ${PYTHON_PN}-profile \ |
27 | ${PYTHON_PN}-zopeinterface \ | ||
25 | " | 28 | " |
26 | 29 | ||
27 | do_install_ptest() { | 30 | do_install_ptest() { |