summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-14 17:52:06 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commitd5df1fe869a9a746438a6ad8c208a170357e7e5a (patch)
treebebcdcacd5cd921d0a91a88a9308142361464b63 /meta-python
parentc3d10cd377406fa3ce7286965bfe64c1b1c67a90 (diff)
downloadmeta-openembedded-d5df1fe869a9a746438a6ad8c208a170357e7e5a.tar.gz
python3-click: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-click.inc25
-rw-r--r--meta-python/recipes-devtools/python/python3-click_7.0.bb26
2 files changed, 25 insertions, 26 deletions
diff --git a/meta-python/recipes-devtools/python/python-click.inc b/meta-python/recipes-devtools/python/python-click.inc
deleted file mode 100644
index f9dfd5627..000000000
--- a/meta-python/recipes-devtools/python/python-click.inc
+++ /dev/null
@@ -1,25 +0,0 @@
1SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
2DESCRIPTION = "\
3Click is a Python package for creating beautiful command line interfaces \
4in a composable way with as little code as necessary. It's the "Command \
5Line Interface Creation Kit". It's highly configurable but comes with \
6sensible defaults out of the box."
7HOMEPAGE = "http://click.pocoo.org/"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=c13ed890b210a882c1778216694c98c7"
10
11SRC_URI[md5sum] = "7f53d50f7b7373ebc7963f9ff697450a"
12SRC_URI[sha256sum] = "5b94b49521f6456670fdb30cd82a4eca9412788a93fa6dd6df72c94d5a8ff2d7"
13
14UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
15
16CLEANBROKEN = "1"
17
18RDEPENDS_${PN} += "\
19 ${PYTHON_PN}-io \
20 ${PYTHON_PN}-threading \
21 "
22
23BBCLASSEXTEND = "native nativesdk"
24
25PYPI_PACKAGE = "Click"
diff --git a/meta-python/recipes-devtools/python/python3-click_7.0.bb b/meta-python/recipes-devtools/python/python3-click_7.0.bb
index 192064404..cfa3e0fe4 100644
--- a/meta-python/recipes-devtools/python/python3-click_7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-click_7.0.bb
@@ -1,2 +1,26 @@
1SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
2DESCRIPTION = "\
3Click is a Python package for creating beautiful command line interfaces \
4in a composable way with as little code as necessary. It's the "Command \
5Line Interface Creation Kit". It's highly configurable but comes with \
6sensible defaults out of the box."
7HOMEPAGE = "http://click.pocoo.org/"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=c13ed890b210a882c1778216694c98c7"
10
11SRC_URI[md5sum] = "7f53d50f7b7373ebc7963f9ff697450a"
12SRC_URI[sha256sum] = "5b94b49521f6456670fdb30cd82a4eca9412788a93fa6dd6df72c94d5a8ff2d7"
13
14PYPI_PACKAGE = "Click"
1inherit pypi setuptools3 15inherit pypi setuptools3
2require python-click.inc 16
17UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
18
19CLEANBROKEN = "1"
20
21RDEPENDS_${PN} += "\
22 ${PYTHON_PN}-io \
23 ${PYTHON_PN}-threading \
24 "
25
26BBCLASSEXTEND = "native nativesdk"