diff options
author | Derek Straka <derek@asterius.io> | 2020-02-14 17:52:06 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-02-15 08:05:07 -0800 |
commit | d5df1fe869a9a746438a6ad8c208a170357e7e5a (patch) | |
tree | bebcdcacd5cd921d0a91a88a9308142361464b63 /meta-python | |
parent | c3d10cd377406fa3ce7286965bfe64c1b1c67a90 (diff) | |
download | meta-openembedded-d5df1fe869a9a746438a6ad8c208a170357e7e5a.tar.gz |
python3-click: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-click.inc | 25 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-click_7.0.bb | 26 |
2 files changed, 25 insertions, 26 deletions
diff --git a/meta-python/recipes-devtools/python/python-click.inc b/meta-python/recipes-devtools/python/python-click.inc deleted file mode 100644 index f9dfd5627..000000000 --- a/meta-python/recipes-devtools/python/python-click.inc +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | SUMMARY = "A simple wrapper around optparse for powerful command line utilities." | ||
2 | DESCRIPTION = "\ | ||
3 | Click is a Python package for creating beautiful command line interfaces \ | ||
4 | in a composable way with as little code as necessary. It's the "Command \ | ||
5 | Line Interface Creation Kit". It's highly configurable but comes with \ | ||
6 | sensible defaults out of the box." | ||
7 | HOMEPAGE = "http://click.pocoo.org/" | ||
8 | LICENSE = "BSD-3-Clause" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=c13ed890b210a882c1778216694c98c7" | ||
10 | |||
11 | SRC_URI[md5sum] = "7f53d50f7b7373ebc7963f9ff697450a" | ||
12 | SRC_URI[sha256sum] = "5b94b49521f6456670fdb30cd82a4eca9412788a93fa6dd6df72c94d5a8ff2d7" | ||
13 | |||
14 | UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/" | ||
15 | |||
16 | CLEANBROKEN = "1" | ||
17 | |||
18 | RDEPENDS_${PN} += "\ | ||
19 | ${PYTHON_PN}-io \ | ||
20 | ${PYTHON_PN}-threading \ | ||
21 | " | ||
22 | |||
23 | BBCLASSEXTEND = "native nativesdk" | ||
24 | |||
25 | PYPI_PACKAGE = "Click" | ||
diff --git a/meta-python/recipes-devtools/python/python3-click_7.0.bb b/meta-python/recipes-devtools/python/python3-click_7.0.bb index 192064404..cfa3e0fe4 100644 --- a/meta-python/recipes-devtools/python/python3-click_7.0.bb +++ b/meta-python/recipes-devtools/python/python3-click_7.0.bb | |||
@@ -1,2 +1,26 @@ | |||
1 | SUMMARY = "A simple wrapper around optparse for powerful command line utilities." | ||
2 | DESCRIPTION = "\ | ||
3 | Click is a Python package for creating beautiful command line interfaces \ | ||
4 | in a composable way with as little code as necessary. It's the "Command \ | ||
5 | Line Interface Creation Kit". It's highly configurable but comes with \ | ||
6 | sensible defaults out of the box." | ||
7 | HOMEPAGE = "http://click.pocoo.org/" | ||
8 | LICENSE = "BSD-3-Clause" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=c13ed890b210a882c1778216694c98c7" | ||
10 | |||
11 | SRC_URI[md5sum] = "7f53d50f7b7373ebc7963f9ff697450a" | ||
12 | SRC_URI[sha256sum] = "5b94b49521f6456670fdb30cd82a4eca9412788a93fa6dd6df72c94d5a8ff2d7" | ||
13 | |||
14 | PYPI_PACKAGE = "Click" | ||
1 | inherit pypi setuptools3 | 15 | inherit pypi setuptools3 |
2 | require python-click.inc | 16 | |
17 | UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/" | ||
18 | |||
19 | CLEANBROKEN = "1" | ||
20 | |||
21 | RDEPENDS_${PN} += "\ | ||
22 | ${PYTHON_PN}-io \ | ||
23 | ${PYTHON_PN}-threading \ | ||
24 | " | ||
25 | |||
26 | BBCLASSEXTEND = "native nativesdk" | ||