summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2022-11-29 15:08:58 +0800
committerKhem Raj <raj.khem@gmail.com>2022-12-05 18:02:40 -0800
commitbd4f8ed7c238e6250c0f3e6a1d30347f1bef68d7 (patch)
treea8cc4f3992166fa2275f38ca493c9fc33bd00bed /meta-python
parentb75c138a1cdfacb4a9fba2a291a0d15f0691526b (diff)
downloadmeta-openembedded-bd4f8ed7c238e6250c0f3e6a1d30347f1bef68d7.tar.gz
python3-wxgtk4: replace deprecated inspect.getargspec
Backport patch to replace deprecated inspect.getargspec in lib pubsub. And add python3-pip to RDEPENDS which is required by utils wxdemo, wxdocs and wxget provided by python3-wxgtk4. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4/0001-pypubsub-Replace-deprecated-inspect.getargspec.patch65
-rw-r--r--meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.0.bb2
2 files changed, 67 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4/0001-pypubsub-Replace-deprecated-inspect.getargspec.patch b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4/0001-pypubsub-Replace-deprecated-inspect.getargspec.patch
new file mode 100644
index 000000000..9bec4c5ba
--- /dev/null
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4/0001-pypubsub-Replace-deprecated-inspect.getargspec.patch
@@ -0,0 +1,65 @@
1Upstream-Status: Backport [https://github.com/wxWidgets/Phoenix/commit/9986a0d5]
2
3Signed-off-by: Kai Kang <kai.kang@windriver.com>
4
5From 9986a0d5c24b5d45ddf571d60351f68765a8a9be Mon Sep 17 00:00:00 2001
6From: Scott Talbert <swt@techie.net>
7Date: Mon, 8 Aug 2022 22:35:58 -0400
8Subject: [PATCH] pypubsub: Replace deprecated inspect.getargspec
9
10inspect.getargspec was removed in Python 3.11. This is a backport of:
11https://github.com/schollii/pypubsub/commit/089c7a73f85c76a3aa22e4b10c71db1bf65a8637
12---
13 wx/lib/pubsub/core/callables.py | 23 +++++++++++++++--------
14 1 file changed, 15 insertions(+), 8 deletions(-)
15
16diff --git a/wx/lib/pubsub/core/callables.py b/wx/lib/pubsub/core/callables.py
17index 65eb1ebe..7e798c54 100644
18--- a/wx/lib/pubsub/core/callables.py
19+++ b/wx/lib/pubsub/core/callables.py
20@@ -12,7 +12,7 @@ CallArgsInfo regarding its autoTopicArgName data member.
21
22 """
23
24-from inspect import getargspec, ismethod, isfunction
25+from inspect import ismethod, isfunction, signature, Parameter
26
27 from .. import py2and3
28
29@@ -133,19 +133,26 @@ class CallArgsInfo:
30 self.autoTopicArgName = None."""
31
32 #args, firstArgIdx, defaultVals, acceptsAllKwargs
33- (allParams, varParamName, varOptParamName, defaultVals) = getargspec(func)
34- if defaultVals is None:
35- defaultVals = []
36- else:
37- defaultVals = list(defaultVals)
38+ allParams = []
39+ defaultVals = []
40+ varParamName = None
41+ varOptParamName = None
42+ for argName, param in signature(func).parameters.items():
43+ if param.default != Parameter.empty:
44+ defaultVals.append(param.default)
45+ if param.kind == Parameter.VAR_POSITIONAL:
46+ varParamName = argName
47+ elif param.kind == Parameter.VAR_KEYWORD:
48+ varOptParamName = argName
49+ else:
50+ allParams.append(argName)
51
52 self.acceptsAllKwargs = (varOptParamName is not None)
53 self.acceptsAllUnnamedArgs = (varParamName is not None)
54-
55 self.allParams = allParams
56- del self.allParams[0:firstArgIdx] # does nothing if firstArgIdx == 0
57
58 self.numRequired = len(self.allParams) - len(defaultVals)
59+ assert len(self.allParams) >= len(defaultVals)
60 assert self.numRequired >= 0
61
62 # if listener wants topic, remove that arg from args/defaultVals
63--
642.34.1
65
diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.0.bb b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.0.bb
index faea43777..df23037fc 100644
--- a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.0.bb
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.0.bb
@@ -13,6 +13,7 @@ PYPI_PACKAGE = "wxPython"
13SRC_URI += "file://add-back-option-build-base.patch \ 13SRC_URI += "file://add-back-option-build-base.patch \
14 file://wxgtk-fixup-build-scripts.patch \ 14 file://wxgtk-fixup-build-scripts.patch \
15 file://not-overwrite-cflags-cxxflags.patch \ 15 file://not-overwrite-cflags-cxxflags.patch \
16 file://0001-pypubsub-Replace-deprecated-inspect.getargspec.patch \
16 " 17 "
17SRC_URI[sha256sum] = "663cebc4509d7e5d113518865fe274f77f95434c5d57bc386ed58d65ceed86c7" 18SRC_URI[sha256sum] = "663cebc4509d7e5d113518865fe274f77f95434c5d57bc386ed58d65ceed86c7"
18 19
@@ -29,6 +30,7 @@ RDEPENDS:${PN} = "\
29 python3-image \ 30 python3-image \
30 python3-numpy \ 31 python3-numpy \
31 python3-pillow \ 32 python3-pillow \
33 python3-pip \
32 python3-pprint \ 34 python3-pprint \
33 python3-pycairo \ 35 python3-pycairo \
34 python3-six \ 36 python3-six \