diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2023-01-04 12:00:14 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-01-06 11:38:16 -0800 |
commit | bbb07140d5024ef15103e67807d03b47bcbd9bc9 (patch) | |
tree | f750d6be50295b29f857ae23eee73e55d71d1c5a /meta-python | |
parent | 211e4988da40f49d46a81017b3047b002b0812b4 (diff) | |
download | meta-openembedded-bbb07140d5024ef15103e67807d03b47bcbd9bc9.tar.gz |
python3-coverage: Upgrade 7.0.1 -> 7.0.3
Upgrade to release 7.0.3:
- Fix: when using the [run] relative_files = True setting, a
relative [paths] pattern was still being made absolute. This is
now fixed.
- Fix: if Python doesn't provide tomllib, then TOML configuration
files can only be read if coverage.py is installed with the
[toml] extra. Coverage.py will raise an error if TOML support is
not installed when it sees your settings are in a .toml file.
But it didn't understand that [tools.coverage] was a valid
section header, so the error wasn't reported if you used that
header, and settings were silently ignored. This is now fixed.
- Fix: adjusted how decorators are traced on PyPy 7.3.10.
- Fix: the coverage lcov report did not properly implement the
--fail-under=MIN option. This has been fixed.
- Refactor: added many type annotations, including a number of
refactorings. This should not affect outward behavior, but they
were a bit invasive in some places, so keep your eyes peeled for
oddities.
- Refactor: removed the vestigial and long untested support for
Jython and IronPython.
- Fix: when using pytest-cov or pytest-xdist, or perhaps both, the
combining step could fail with assert row is not None using
7.0.2. This was due to a race condition that has always been
possible and is still possible. In 7.0.1 and before, the error
was silently swallowed by the combining code. Now it will produce
a message "Couldn't combine data file" and ignore the data file
as it used to do before 7.0.2
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-coverage_7.0.3.bb (renamed from meta-python/recipes-devtools/python/python3-coverage_7.0.1.bb) | 4 |
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-coverage_7.0.1.bb b/meta-python/recipes-devtools/python/python3-coverage_7.0.3.bb index caf6ba14f..7e9b262d1 100644 --- a/meta-python/recipes-devtools/python/python3-coverage_7.0.1.bb +++ b/meta-python/recipes-devtools/python/python3-coverage_7.0.3.bb | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "https://coverage.readthedocs.io" | |||
3 | LICENSE = "Apache-2.0" | 3 | LICENSE = "Apache-2.0" |
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93" | 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93" |
5 | 5 | ||
6 | SRC_URI[sha256sum] = "a4a574a19eeb67575a5328a5760bbbb737faa685616586a9f9da4281f940109c" | 6 | SRC_URI[sha256sum] = "d5be4e93acce64f516bf4fd239c0e6118fc913c93fa1a3f52d15bdcc60d97b2d" |
7 | 7 | ||
8 | inherit pypi setuptools3 | 8 | inherit pypi setuptools3 |
9 | 9 | ||
@@ -16,4 +16,6 @@ RDEPENDS:${PN} += " \ | |||
16 | ${PYTHON_PN}-crypt \ | 16 | ${PYTHON_PN}-crypt \ |
17 | ${PYTHON_PN}-shell \ | 17 | ${PYTHON_PN}-shell \ |
18 | ${PYTHON_PN}-io \ | 18 | ${PYTHON_PN}-io \ |
19 | ${PYTHON_PN}-toml \ | ||
20 | ${PYTHON_PN}-multiprocessing \ | ||
19 | " | 21 | " |