diff options
author | Tim Orling <ticotimo@gmail.com> | 2024-02-16 16:15:41 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-16 16:42:38 -0800 |
commit | a62b699bcb5007fbda40ac39bd5c29f1c2a73512 (patch) | |
tree | bd4907040196fa4b31c3183ea3316b8e288f5b14 /meta-python | |
parent | ee5a7f0c38498d9c0d26832701aa85b7877f47db (diff) | |
download | meta-openembedded-a62b699bcb5007fbda40ac39bd5c29f1c2a73512.tar.gz |
python3-semver: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-semver/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-semver_3.0.2.bb | 3 |
2 files changed, 3 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-semver/run-ptest b/meta-python/recipes-devtools/python/python3-semver/run-ptest index cd2bc8537..8d2017d39 100644 --- a/meta-python/recipes-devtools/python/python3-semver/run-ptest +++ b/meta-python/recipes-devtools/python/python3-semver/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO tests/test_semver.py --disable-warnings| sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-semver_3.0.2.bb b/meta-python/recipes-devtools/python/python3-semver_3.0.2.bb index f90ea0c9d..25222bb5f 100644 --- a/meta-python/recipes-devtools/python/python3-semver_3.0.2.bb +++ b/meta-python/recipes-devtools/python/python3-semver_3.0.2.bb | |||
@@ -17,7 +17,8 @@ SRC_URI += " \ | |||
17 | DEPENDS += " python3-setuptools-scm-native" | 17 | DEPENDS += " python3-setuptools-scm-native" |
18 | 18 | ||
19 | RDEPENDS:${PN}-ptest += " \ | 19 | RDEPENDS:${PN}-ptest += " \ |
20 | ${PYTHON_PN}-pytest \ | 20 | python3-pytest \ |
21 | python3-unittest-automake-output \ | ||
21 | " | 22 | " |
22 | 23 | ||
23 | do_install_ptest() { | 24 | do_install_ptest() { |