diff options
author | Tim Orling <ticotimo@gmail.com> | 2024-02-16 16:15:24 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-16 16:42:35 -0800 |
commit | a32aeade02fe4618b8ecebe5a6e0fd63c4b8a359 (patch) | |
tree | b6a46eb7f966072978f5045e303d22f7bc9a40a5 /meta-python | |
parent | d3b75642db2bbf0685287a66148343007e17fffa (diff) | |
download | meta-openembedded-a32aeade02fe4618b8ecebe5a6e0fd63c4b8a359.tar.gz |
python3-serpent: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3
* Remove trailing whitespace
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-serpent/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-serpent_1.41.bb | 11 |
2 files changed, 7 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python3-serpent/run-ptest b/meta-python/recipes-devtools/python/python3-serpent/run-ptest index b63c4de0d..8d2017d39 100644 --- a/meta-python/recipes-devtools/python/python3-serpent/run-ptest +++ b/meta-python/recipes-devtools/python/python3-serpent/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-serpent_1.41.bb b/meta-python/recipes-devtools/python/python3-serpent_1.41.bb index 480e3ab38..941b5ee0f 100644 --- a/meta-python/recipes-devtools/python/python3-serpent_1.41.bb +++ b/meta-python/recipes-devtools/python/python3-serpent_1.41.bb | |||
@@ -11,8 +11,9 @@ SRC_URI += " \ | |||
11 | " | 11 | " |
12 | 12 | ||
13 | RDEPENDS:${PN}-ptest += " \ | 13 | RDEPENDS:${PN}-ptest += " \ |
14 | ${PYTHON_PN}-pytest \ | 14 | python3-pytest \ |
15 | ${PYTHON_PN}-pytz \ | 15 | python3-pytz \ |
16 | python3-unittest-automake-output \ | ||
16 | " | 17 | " |
17 | 18 | ||
18 | do_install_ptest() { | 19 | do_install_ptest() { |
@@ -21,6 +22,6 @@ do_install_ptest() { | |||
21 | } | 22 | } |
22 | 23 | ||
23 | RDEPENDS:${PN} += "\ | 24 | RDEPENDS:${PN} += "\ |
24 | ${PYTHON_PN}-netclient \ | 25 | python3-netclient \ |
25 | ${PYTHON_PN}-numbers \ | 26 | python3-numbers \ |
26 | " | 27 | " |