diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-06-22 20:41:46 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-06-24 12:54:18 -0700 |
commit | 9e456c6908d2579657674c7cb41934c24ddb9ef7 (patch) | |
tree | 60f086653bc54bf7b85654a27eedd94277dc6d75 /meta-python | |
parent | 0b19534f5e1cad8a272978ee8dfe9454220fe158 (diff) | |
download | meta-openembedded-9e456c6908d2579657674c7cb41934c24ddb9ef7.tar.gz |
python3-execnet: Add ptests
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-execnet/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb | 15 |
2 files changed, 15 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-execnet/run-ptest b/meta-python/recipes-devtools/python/python3-execnet/run-ptest new file mode 100644 index 000000000..b63c4de0d --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-execnet/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb b/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb index ec16e8884..a7b156535 100644 --- a/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb +++ b/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb | |||
@@ -6,13 +6,22 @@ HOMEPAGE = "https://execnet.readthedocs.io/en/latest/" | |||
6 | LICENSE = "MIT" | 6 | LICENSE = "MIT" |
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e" | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e" |
8 | 8 | ||
9 | DEPENDS += "python3-pip-native" | ||
10 | |||
11 | SRC_URI += "file://run-ptest \ | ||
12 | " | ||
9 | SRC_URI[sha256sum] = "8f694f3ba9cc92cab508b152dcfe322153975c29bda272e2fd7f3f00f36e47c5" | 13 | SRC_URI[sha256sum] = "8f694f3ba9cc92cab508b152dcfe322153975c29bda272e2fd7f3f00f36e47c5" |
10 | 14 | ||
11 | DEPENDS += "python3-pip-native" | 15 | inherit ptest pypi setuptools3 |
12 | 16 | ||
13 | inherit pypi setuptools3 | 17 | do_install_ptest() { |
18 | install -d ${D}${PTEST_PATH}/tests | ||
19 | cp -rf ${S}/testing/* ${D}${PTEST_PATH}/tests/ | ||
20 | } | ||
14 | 21 | ||
15 | PACKAGECONFIG[testing] = ",,,python3-pre-commit" | 22 | RDEPENDS_${PN}-ptest += "\ |
23 | python3-pytest \ | ||
24 | " | ||
16 | 25 | ||
17 | RDEPENDS_${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading" | 26 | RDEPENDS_${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading" |
18 | 27 | ||