diff options
author | Tim Orling <ticotimo@gmail.com> | 2024-02-16 16:15:14 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-16 16:42:34 -0800 |
commit | 8667e7db0f48120b39a5cba8519d68835212f87d (patch) | |
tree | 7cc8cfb5c9aeb7f312ab0ea96c13bdff731699be /meta-python | |
parent | a55a9b65f4c553a27533ab3a671149c44ff28566 (diff) | |
download | meta-openembedded-8667e7db0f48120b39a5cba8519d68835212f87d.tar.gz |
python3-dnspython: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-dnspython/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-dnspython_2.5.0.bb | 19 |
2 files changed, 11 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dnspython/run-ptest b/meta-python/recipes-devtools/python/python3-dnspython/run-ptest index b63c4de0d..8d2017d39 100644 --- a/meta-python/recipes-devtools/python/python3-dnspython/run-ptest +++ b/meta-python/recipes-devtools/python/python3-dnspython/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-dnspython_2.5.0.bb b/meta-python/recipes-devtools/python/python3-dnspython_2.5.0.bb index 6b7212b9b..c5c8d42e2 100644 --- a/meta-python/recipes-devtools/python/python3-dnspython_2.5.0.bb +++ b/meta-python/recipes-devtools/python/python3-dnspython_2.5.0.bb | |||
@@ -12,7 +12,8 @@ SRC_URI += " \ | |||
12 | " | 12 | " |
13 | 13 | ||
14 | RDEPENDS:${PN}-ptest += " \ | 14 | RDEPENDS:${PN}-ptest += " \ |
15 | ${PYTHON_PN}-pytest \ | 15 | python3-pytest \ |
16 | python3-unittest-automake-output \ | ||
16 | " | 17 | " |
17 | 18 | ||
18 | do_install_ptest() { | 19 | do_install_ptest() { |
@@ -21,15 +22,15 @@ do_install_ptest() { | |||
21 | } | 22 | } |
22 | 23 | ||
23 | DEPENDS += "\ | 24 | DEPENDS += "\ |
24 | ${PYTHON_PN}-wheel-native \ | 25 | python3-wheel-native \ |
25 | ${PYTHON_PN}-setuptools-scm-native \ | 26 | python3-setuptools-scm-native \ |
26 | " | 27 | " |
27 | 28 | ||
28 | RDEPENDS:${PN} += " \ | 29 | RDEPENDS:${PN} += " \ |
29 | ${PYTHON_PN}-crypt \ | 30 | python3-crypt \ |
30 | ${PYTHON_PN}-io \ | 31 | python3-io \ |
31 | ${PYTHON_PN}-math \ | 32 | python3-math \ |
32 | ${PYTHON_PN}-netclient \ | 33 | python3-netclient \ |
33 | ${PYTHON_PN}-numbers \ | 34 | python3-numbers \ |
34 | ${PYTHON_PN}-threading \ | 35 | python3-threading \ |
35 | " | 36 | " |