summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-02-19 17:02:19 +0800
committerKhem Raj <raj.khem@gmail.com>2024-02-19 23:22:21 -0800
commit4e7660118b02bc1363f03bdd6ed13a863abe8f61 (patch)
tree61e6b8d19e8be83c8fe9b10aec4579ee902b7341 /meta-python
parenta941a5b3b59be423701d7018efeb715c01a09263 (diff)
downloadmeta-openembedded-4e7660118b02bc1363f03bdd6ed13a863abe8f61.tar.gz
python3-bidict: upgrade 0.22.1 -> 0.23.0
License-Update: Copyright year updated to 2024 Changelog: ============ -Drop support for Python 3.7, which reached end of life on 2023-06-27, and take advantage of features available in Python 3.8+. -Remove FrozenOrderedBidict now that Python 3.7 is no longer supported. -Remove namedbidict due to low usage. -Remove the kv field of OnDup which specified the OnDupAction to take in the case of Key and Value Duplication. -Improve type hints for the inv shortcut alias for inverse. -Fix a bug where calls like bidict(None), bi.update(False) -All __init__(), update(), and related methods now handle SupportsKeysAndGetItem objects that are not Mappings the same way that MutableMapping.update() does, before falling back to handling the provided object as an iterable of pairs. -The repr() of ordered bidicts now matches that of regular bidicts -This tracks with the change to collections.OrderedDict's repr() in Python 3.12. -Test with Python 3.12 in CI. -Drop use of Trove classifiers that declare support for specific Python versions in package metadata. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-bidict_0.23.0.bb (renamed from meta-python/recipes-devtools/python/python3-bidict_0.22.1.bb)4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bidict_0.22.1.bb b/meta-python/recipes-devtools/python/python3-bidict_0.23.0.bb
index 1ed0af81a..5667e4927 100644
--- a/meta-python/recipes-devtools/python/python3-bidict_0.22.1.bb
+++ b/meta-python/recipes-devtools/python/python3-bidict_0.23.0.bb
@@ -2,9 +2,9 @@ SUMMARY = "The bidirectional mapping library for Python."
2DESCRIPTION = "The bidirectional mapping library for Python." 2DESCRIPTION = "The bidirectional mapping library for Python."
3HOMEPAGE = "https://bidict.readthedocs.io/" 3HOMEPAGE = "https://bidict.readthedocs.io/"
4LICENSE = "MPL-2.0" 4LICENSE = "MPL-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=858e74278ef3830d46481172ae03c819" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=e907308cc9356afa99ac0eec6b20211b"
6 6
7SRC_URI[sha256sum] = "1e0f7f74e4860e6d0943a05d4134c63a2fad86f3d4732fb265bd79e4e856d81d" 7SRC_URI[sha256sum] = "3959ca59d4d6997702d642bf1e5fd93cba299863723fc289545198f70c468578"
8 8
9inherit pypi python_setuptools_build_meta 9inherit pypi python_setuptools_build_meta
10 10