summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:05 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:33 -0800
commit4a392ddd3b279de96597f93de9e11b051cdebde5 (patch)
treee3e422a481800dea110212af6fd37140276d79b7 /meta-python
parent5cb0fc02c16bc50d87d5d754e8635e4e1ed359b0 (diff)
downloadmeta-openembedded-4a392ddd3b279de96597f93de9e11b051cdebde5.tar.gz
python3-trustme: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-trustme/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-trustme_1.1.0.bb7
2 files changed, 5 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-trustme/run-ptest b/meta-python/recipes-devtools/python/python3-trustme/run-ptest
index b63c4de0d..8d2017d39 100644
--- a/meta-python/recipes-devtools/python/python3-trustme/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-trustme/run-ptest
@@ -1,3 +1,3 @@
1#!/bin/sh 1#!/bin/sh
2 2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' 3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-trustme_1.1.0.bb b/meta-python/recipes-devtools/python/python3-trustme_1.1.0.bb
index e925712f3..ac03bce2b 100644
--- a/meta-python/recipes-devtools/python/python3-trustme_1.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-trustme_1.1.0.bb
@@ -20,9 +20,10 @@ RDEPENDS:${PN} += " \
20" 20"
21 21
22RDEPENDS:${PN}-ptest += " \ 22RDEPENDS:${PN}-ptest += " \
23 ${PYTHON_PN}-pytest \ 23 python3-pyasn1-modules \
24 ${PYTHON_PN}-service-identity \ 24 python3-pytest \
25 ${PYTHON_PN}-pyasn1-modules \ 25 python3-service-identity \
26 python3-unittest-automake-output \
26" 27"
27 28
28do_install_ptest() { 29do_install_ptest() {