diff options
author | Tim Orling <ticotimo@gmail.com> | 2024-02-16 16:15:08 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-16 16:42:33 -0800 |
commit | 4201621f4574172aebdadf50fc8c3a7930871aac (patch) | |
tree | e4caf7d51f2d1964b0fc1e4de28343c0ccc4444e /meta-python | |
parent | aaa00e26053c756570b6f2678c3d70ba0a8d20e9 (diff) | |
download | meta-openembedded-4201621f4574172aebdadf50fc8c3a7930871aac.tar.gz |
python3-pyasn1-modules: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyasn1-modules/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyasn1-modules_0.3.0.bb | 5 |
2 files changed, 4 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyasn1-modules/run-ptest b/meta-python/recipes-devtools/python/python3-pyasn1-modules/run-ptest index b63c4de0d..8d2017d39 100644 --- a/meta-python/recipes-devtools/python/python3-pyasn1-modules/run-ptest +++ b/meta-python/recipes-devtools/python/python3-pyasn1-modules/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.3.0.bb b/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.3.0.bb index d158876fc..ccd6025be 100644 --- a/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.3.0.bb +++ b/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.3.0.bb | |||
@@ -12,7 +12,7 @@ PYPI_PACKAGE = "pyasn1_modules" | |||
12 | 12 | ||
13 | inherit pypi ptest setuptools3 | 13 | inherit pypi ptest setuptools3 |
14 | 14 | ||
15 | RDEPENDS:${PN} = "${PYTHON_PN}-pyasn1" | 15 | RDEPENDS:${PN} = "python3-pyasn1" |
16 | 16 | ||
17 | BBCLASSEXTEND = "native nativesdk" | 17 | BBCLASSEXTEND = "native nativesdk" |
18 | 18 | ||
@@ -21,7 +21,8 @@ SRC_URI += " \ | |||
21 | " | 21 | " |
22 | 22 | ||
23 | RDEPENDS:${PN}-ptest += " \ | 23 | RDEPENDS:${PN}-ptest += " \ |
24 | ${PYTHON_PN}-pytest \ | 24 | python3-pytest \ |
25 | python3-unittest-automake-output \ | ||
25 | " | 26 | " |
26 | 27 | ||
27 | do_install_ptest() { | 28 | do_install_ptest() { |