summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-04-10 16:30:47 +0800
committerKhem Raj <raj.khem@gmail.com>2023-04-10 09:39:38 -0700
commit3c49711ad7e17ec01f43f1e3c861be1ecba02dd2 (patch)
tree1806fd75b1c6b98f12bd83175f79a004c52f1f49 /meta-python
parent82ce84ecc691d511524dacb8e162e840bf5bdda8 (diff)
downloadmeta-openembedded-3c49711ad7e17ec01f43f1e3c861be1ecba02dd2.tar.gz
python3-simplejson: upgrade 3.18.4 -> 3.19.1
Changelog: ============ * This release contains security hardening measures based on recommendations by a security audit sponsored by OSTIF and conducted by X41 D-Sec GmbH. Several of these measures include changing defaults to be more strict, by default simplejson will now only consume and produce compliant JSON, but the flags still exist for any backwards compatibility needs. No high priority issues were discovered, the reference count leak is thought to be unreachable since the digits of the float are checked before PyOS_string_to_double is called. A link to the public version of this report will be included in a future release of simplejson. The following fixes were implemented in one PR: https://github.com/simplejson/simplejson/pull/313 * Fix invalid handling of unicode escape sequences in the pure Python implementation of the decoder (SJ-PT-23-01) * Fix missing reference count decrease if PyOS_string_to_double raises an exception in Python 2.x; was probably unreachable (SJ-PT-23-02) * Backport the integer string length limitation from Python 3.11 to limit quadratic number parsing (SJ-PT-23-03) * Fix inconsistencies with error messages between the C and Python implementations (SJ-PT-23-100) * Remove unused unichr import from encoder (SJ-PT-23-101) * Remove unused namedtuple_as_object and tuple_as_array arguments from simplejson.load (SJ-PT-23-102) * Remove vestigial _one_shot code from iterencode (SJ-PT-23-103) * Change default of allow_nan from True to False and add allow_nan to decoder (SJ-PT-23-107) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-simplejson_3.19.1.bb (renamed from meta-python/recipes-devtools/python/python3-simplejson_3.18.4.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-simplejson_3.18.4.bb b/meta-python/recipes-devtools/python/python3-simplejson_3.19.1.bb
index e7d6ca0cf..1fb31a3a3 100644
--- a/meta-python/recipes-devtools/python/python3-simplejson_3.18.4.bb
+++ b/meta-python/recipes-devtools/python/python3-simplejson_3.19.1.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e" 5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e"
6 6
7SRC_URI[sha256sum] = "6197cfebe659ac802a686b5408494115a7062b45cdf37679c4d6a9d4f39649b7" 7SRC_URI[sha256sum] = "6277f60848a7d8319d27d2be767a7546bc965535b28070e310b3a9af90604a4c"
8 8
9inherit pypi setuptools3 9inherit pypi setuptools3
10 10