diff options
author | Derek Straka <derek@asterius.io> | 2020-02-15 12:43:10 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-02-16 12:52:19 -0800 |
commit | 2dd02608735cf61e78cee97aa63bc80417d1652e (patch) | |
tree | 321c9b3b4f76ed8c7d61bc1f10ffa8bc765f8c86 /meta-python | |
parent | 97c41dcd671efb1497a0128a886ad949b4ceb58d (diff) | |
download | meta-openembedded-2dd02608735cf61e78cee97aa63bc80417d1652e.tar.gz |
python3-constantly: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-constantly.inc | 11 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb | 13 |
2 files changed, 11 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python-constantly.inc b/meta-python/recipes-devtools/python/python-constantly.inc deleted file mode 100644 index 815350492..000000000 --- a/meta-python/recipes-devtools/python/python-constantly.inc +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | DESCRIPTION = "Symbolic constants in Python" | ||
2 | HOMEPAGE = "https://github.com/twisted/constantly" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e393e4ddd223e3a74982efa784f89fd7" | ||
5 | |||
6 | SRC_URI[md5sum] = "f0762f083d83039758e53f8cf0086eef" | ||
7 | SRC_URI[sha256sum] = "586372eb92059873e29eba4f9dec8381541b4d3834660707faf8ba59146dfc35" | ||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | RDEPENDS_${PN} += "${PYTHON_PN}-json" | ||
diff --git a/meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb b/meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb index 3f667540d..ad24f6de6 100644 --- a/meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb +++ b/meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb | |||
@@ -1,2 +1,11 @@ | |||
1 | inherit setuptools3 | 1 | DESCRIPTION = "Symbolic constants in Python" |
2 | require python-constantly.inc | 2 | HOMEPAGE = "https://github.com/twisted/constantly" |
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e393e4ddd223e3a74982efa784f89fd7" | ||
5 | |||
6 | SRC_URI[md5sum] = "f0762f083d83039758e53f8cf0086eef" | ||
7 | SRC_URI[sha256sum] = "586372eb92059873e29eba4f9dec8381541b4d3834660707faf8ba59146dfc35" | ||
8 | |||
9 | inherit pypi setuptools3 | ||
10 | |||
11 | RDEPENDS_${PN} += "${PYTHON_PN}-json" | ||