diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2021-10-26 14:48:22 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-10-28 09:01:25 -0700 |
commit | 295e6dd96c398a2220d8fefc3c83ad735c9e92ca (patch) | |
tree | c760c8d2b5d1e18c0307fc97e0b86f556ca59138 /meta-python | |
parent | a57273d1fa2eb168e3eea61ba5270f314afe5d5f (diff) | |
download | meta-openembedded-295e6dd96c398a2220d8fefc3c83ad735c9e92ca.tar.gz |
python3-paho-mqtt: Upgrade 1.5.1 -> 1.6.1
Upgrade to release 1.6.1:
- Fix Python 2.7 compatilibity.
- Changed default TLS version to 1.2 instead of 1.0.
- Fix incoming MQTT v5 messages with overall property length > 127
bytes being incorrectly decoded. Closes #541.
- MQTTMessageInfo.wait_for_publish() and MQTTMessageInfo.is_published()
will now raise exceptions if called when the publish call
produced an error.
- Remove periodic retry checks for outgoing messages with QoS>0.
This means that outgoing messages will only be retried on the
client reconnecting to the server. They will *not* be retried
when the client is still connected.
- The `rc` parameter in the `on_disconnect` callback now has
meaningful values in the case of an error.
- Callbacks can now be applied to client instances using decorators.
- PUBACK messages are now sent to the broker only after the
on_message callback has returned.
- Raise exceptions when attempting to set MQTT v5 properties to
forbidden values.
- Callbacks can now be updated from within a callback.
- Remove _out_packet_mutex and _current_out_packet_mutex and
convert the _out_packet queue use to thread safe.
- Add basic MQTT v5 support to the subscribe and publish helper
functions.
- Fix on_disconnect() sometimes calling the MQTT v3.x callback
when it should call the MQTT v5 callback.
- Big performance improvement when receiving large payloads,
particularly for SSL.
- Fix connecting with MQTT v5 to a broker that doesn't support
MQTT v5.
- Removed ancient Mosquitto compatibility class.
- Fix exception on calling Client(client_id="", clean_session=False).
- Experimental support for Websockets continuation frames.
- `Properties.json()` now converts Correlation Data bytes()
objects to hex.
- Only use the internal sockpair wakeup when running with
loop_start() or loop(). This removes problems when running with
an external event loop.
- Drain all of sockpairR bytes to avoid unnecessary wakeups and
possible timeouts.
- Add timeout to MQTTMessageInfo:wait_for_publish().
License-Update: Update to EPL-2.0
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-paho-mqtt_1.6.1.bb (renamed from meta-python/recipes-devtools/python/python3-paho-mqtt_1.5.1.bb) | 8 |
1 files changed, 3 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-paho-mqtt_1.5.1.bb b/meta-python/recipes-devtools/python/python3-paho-mqtt_1.6.1.bb index 2d4e55abc..81a6d0a9c 100644 --- a/meta-python/recipes-devtools/python/python3-paho-mqtt_1.5.1.bb +++ b/meta-python/recipes-devtools/python/python3-paho-mqtt_1.6.1.bb | |||
@@ -1,15 +1,13 @@ | |||
1 | SUMMARY = "MQTT version 3.1/3.1.1 client library" | 1 | SUMMARY = "MQTT version 3.1/3.1.1 client library" |
2 | LICENSE = "EPL-1.0 | EDL-1.0" | 2 | LICENSE = "EPL-1.0 | EDL-1.0" |
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eb48c6ee2cb9f5b8b9fe75e6f817bdfc \ | 3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e5f264c6988aec56808a3a11e77b913 \ |
4 | file://epl-v10;md5=8d383c379e91d20ba18a52c3e7d3a979 \ | ||
5 | file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \ | 4 | file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \ |
6 | " | 5 | " |
7 | SRCNAME = "paho-mqtt" | 6 | SRCNAME = "paho-mqtt" |
8 | 7 | ||
9 | inherit pypi setuptools3 | 8 | inherit pypi setuptools3 |
10 | 9 | ||
11 | SRC_URI[md5sum] = "32f93c0ed92c7439f7a715ed258fd35d" | 10 | SRC_URI[sha256sum] = "2a8291c81623aec00372b5a85558a372c747cbca8e9934dfe218638b8eefc26f" |
12 | SRC_URI[sha256sum] = "9feb068e822be7b3a116324e01fb6028eb1d66412bf98595ae72698965cb1cae" | ||
13 | 11 | ||
14 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" | 12 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" |
15 | 13 | ||
@@ -20,7 +18,7 @@ do_install:append() { | |||
20 | 18 | ||
21 | PACKAGES =+ "${PN}-examples" | 19 | PACKAGES =+ "${PN}-examples" |
22 | 20 | ||
23 | RDEPENDS:${PN}-examples += "${PN}" | 21 | RDEPENDS:${PN}-examples += "${PN} ${PYTHON_PN}-core" |
24 | 22 | ||
25 | FILES:${PN}-examples = "${datadir}/${BPN}/examples" | 23 | FILES:${PN}-examples = "${datadir}/${BPN}/examples" |
26 | 24 | ||