summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorSergey Kizunov <sergey.kizunov@ni.com>2022-07-26 11:10:32 -0500
committerKhem Raj <raj.khem@gmail.com>2022-07-26 20:49:05 -0400
commit283204e24c826e94ad71da664ca2096b1912bad8 (patch)
tree2f0d947446f27871dd86731ec2aed825214ebc97 /meta-python
parent1d75a01bb5bc00e964a64ded8a445f7fca13c5d7 (diff)
downloadmeta-openembedded-283204e24c826e94ad71da664ca2096b1912bad8.tar.gz
Add python3-aiodns 3.0.0
aiodns is a Python module for asynchronous DNS resolution using pycares. Signed-off-by: Sergey Kizunov <sergey.kizunov@ni.com> Updated and converted to new recipe syntax. Signed-off-by: Brenda Streiff <brenda.streiff@ni.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiodns_3.0.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiodns_3.0.0.bb b/meta-python/recipes-devtools/python/python3-aiodns_3.0.0.bb
new file mode 100644
index 000000000..64599d43c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiodns_3.0.0.bb
@@ -0,0 +1,17 @@
1SUMMARY = "Simple DNS resolver for asyncio"
2DESCRIPTION = "aiodns provides a simple way for doing asynchronous DNS resolutions using pycares."
3HOMEPAGE = "https://github.com/saghul/aiodns"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a565d8b5d06b9620968a135a2657b093"
6
7SRC_URI[md5sum] = "181e11935c78965de2b2b7b0e5efba8d"
8SRC_URI[sha256sum] = "946bdfabe743fceeeb093c8a010f5d1645f708a241be849e17edfb0e49e08cd6"
9
10PYPI_PACKAGE = "aiodns"
11
12inherit pypi setuptools3
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-asyncio \
16 ${PYTHON_PN}-pycares \
17"