diff options
author | Tim Orling <ticotimo@gmail.com> | 2024-02-16 16:15:35 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-16 16:42:37 -0800 |
commit | 23de36be41b607db156f67a2e7b47045e79de822 (patch) | |
tree | 7e6c0b05e8af77e7d22d349bd2e4d9b84705af89 /meta-python | |
parent | 0a982fba812243058a81a42d3e586b112376c17c (diff) | |
download | meta-openembedded-23de36be41b607db156f67a2e7b47045e79de822.tar.gz |
python3-blinker: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 6 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-blinker/run-ptest b/meta-python/recipes-devtools/python/python3-blinker/run-ptest index 15c3f6282..69cd362f6 100644 --- a/meta-python/recipes-devtools/python/python3-blinker/run-ptest +++ b/meta-python/recipes-devtools/python/python3-blinker/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-blinker_1.7.0.bb b/meta-python/recipes-devtools/python/python3-blinker_1.7.0.bb index f1d8b4fa9..8f2cf4883 100644 --- a/meta-python/recipes-devtools/python/python3-blinker_1.7.0.bb +++ b/meta-python/recipes-devtools/python/python3-blinker_1.7.0.bb | |||
@@ -9,11 +9,12 @@ inherit pypi python_setuptools_build_meta ptest | |||
9 | SRC_URI += "file://run-ptest" | 9 | SRC_URI += "file://run-ptest" |
10 | 10 | ||
11 | RDEPENDS:${PN} += "\ | 11 | RDEPENDS:${PN} += "\ |
12 | ${PYTHON_PN}-asyncio \ | 12 | python3-asyncio \ |
13 | " | 13 | " |
14 | 14 | ||
15 | RDEPENDS:${PN}-ptest += " \ | 15 | RDEPENDS:${PN}-ptest += " \ |
16 | ${PYTHON_PN}-pytest \ | 16 | python3-pytest \ |
17 | python3-unittest-automake-output \ | ||
17 | " | 18 | " |
18 | 19 | ||
19 | do_install_ptest() { | 20 | do_install_ptest() { |
diff --git a/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb b/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb index dbde8963e..5c6f4e235 100644 --- a/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb +++ b/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb | |||
@@ -13,8 +13,8 @@ SRC_URI +=" \ | |||
13 | file://run-ptest \ | 13 | file://run-ptest \ |
14 | " | 14 | " |
15 | 15 | ||
16 | RDEPENDS:${PN}_ptest +=" \ | 16 | RDEPENDS:${PN}-ptest +=" \ |
17 | python3_pytest \ | 17 | python3-pytest \ |
18 | python3-unittest-automake-output \ | 18 | python3-unittest-automake-output \ |
19 | " | 19 | " |
20 | 20 | ||