diff options
author | Fabio Berton <fabio.berton@ossystems.com.br> | 2015-08-31 16:08:24 -0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-09-08 16:25:21 +0200 |
commit | 2315f412f625a85e683cf294356b651dcd05a029 (patch) | |
tree | f14b803e5324c544a8085b08ef2f2d5167cbba16 /meta-python | |
parent | 675a49ef0a6b76fd652e4b57ccbbe8b1e1085ec6 (diff) | |
download | meta-openembedded-2315f412f625a85e683cf294356b651dcd05a029.tar.gz |
python-pyroute2: Add recipe
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch | 26 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-pyroute2_0.3.12.bb | 14 |
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch b/meta-python/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch new file mode 100644 index 000000000..d73da07d2 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | Upstream-Status: Inappropriate [wrong dependency] | ||
2 | |||
3 | Subject: [PATCH] import simplejson as json | ||
4 | |||
5 | At runtime python-pyroute2 tries to import json, but the module is not | ||
6 | available, import simplejson as json solve the issue. | ||
7 | |||
8 | Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> | ||
9 | --- | ||
10 | pyroute2/netlink/rtnl/ifinfmsg.py | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/pyroute2/netlink/rtnl/ifinfmsg.py b/pyroute2/netlink/rtnl/ifinfmsg.py | ||
14 | index 4f14f25..55643eb 100644 | ||
15 | --- a/pyroute2/netlink/rtnl/ifinfmsg.py | ||
16 | +++ b/pyroute2/netlink/rtnl/ifinfmsg.py | ||
17 | @@ -1,5 +1,5 @@ | ||
18 | import os | ||
19 | -import json | ||
20 | +import simplejson as json | ||
21 | import errno | ||
22 | import select | ||
23 | import struct | ||
24 | -- | ||
25 | 2.1.4 | ||
26 | |||
diff --git a/meta-python/recipes-devtools/python/python-pyroute2_0.3.12.bb b/meta-python/recipes-devtools/python/python-pyroute2_0.3.12.bb new file mode 100644 index 000000000..d809d9718 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pyroute2_0.3.12.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | DESCRIPTION = "A pure Python netlink and Linux network configuration library" | ||
2 | LICENSE = "BSD" | ||
3 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=270323035ef766597dabd91747c36e3d" | ||
4 | |||
5 | SRC_URI[md5sum] = "5d83ec82acb54ab88c98f0d25d13308b" | ||
6 | SRC_URI[sha256sum] = "c0e1637a75e099104f14d9e03fd5a698dfcc923a22fbfac4a19bd7e94d1fcaa5" | ||
7 | |||
8 | SRC_URI += "file://import-simplejson-as-json.patch" | ||
9 | |||
10 | inherit pypi | ||
11 | |||
12 | RDEPENDS_${PN} = "python-distutils \ | ||
13 | python-simplejson \ | ||
14 | " | ||