summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:17 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:34 -0800
commit10c10c68b776ade64c4948b4e2e5a123887131d8 (patch)
tree800672609d2c0f748ea234fba7515c18b2b8c655 /meta-python
parentc576a146a567cda63e06eae1e63dd8060a77b238 (diff)
downloadmeta-openembedded-10c10c68b776ade64c4948b4e2e5a123887131d8.tar.gz
python3-gunicorn: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-gunicorn/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-gunicorn_21.2.0.bb9
2 files changed, 6 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gunicorn/run-ptest b/meta-python/recipes-devtools/python/python3-gunicorn/run-ptest
index 98d73fa03..5ca7e26e8 100644
--- a/meta-python/recipes-devtools/python/python3-gunicorn/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-gunicorn/run-ptest
@@ -4,4 +4,4 @@
4# ptests to work, so make sure there's at least one nameserver line 4# ptests to work, so make sure there's at least one nameserver line
5echo "nameserver 8.8.8.8" >> /etc/resolv.conf 5echo "nameserver 8.8.8.8" >> /etc/resolv.conf
6 6
7pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' 7pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-gunicorn_21.2.0.bb b/meta-python/recipes-devtools/python/python3-gunicorn_21.2.0.bb
index d765c8fd0..9fd601c99 100644
--- a/meta-python/recipes-devtools/python/python3-gunicorn_21.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-gunicorn_21.2.0.bb
@@ -12,9 +12,10 @@ SRC_URI += " \
12" 12"
13 13
14RDEPENDS:${PN}-ptest += " \ 14RDEPENDS:${PN}-ptest += " \
15 ${PYTHON_PN}-eventlet \ 15 python3-eventlet \
16 ${PYTHON_PN}-gevent \ 16 python3-gevent \
17 ${PYTHON_PN}-pytest \ 17 python3-pytest \
18 python3-unittest-automake-output \
18" 19"
19 20
20do_install_ptest() { 21do_install_ptest() {
@@ -22,4 +23,4 @@ do_install_ptest() {
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ 23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23} 24}
24 25
25RDEPENDS:${PN} += "${PYTHON_PN}-setuptools ${PYTHON_PN}-fcntl" 26RDEPENDS:${PN} += "python3-setuptools python3-fcntl"