summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-12-30 23:58:37 -0800
committerKhem Raj <raj.khem@gmail.com>2022-12-31 10:40:32 -0800
commit0c3d0146a4fb5004d47d333771d013c1c44baf22 (patch)
treee04476f11a308dd1c5a13f3c96506acb8c3cce03 /meta-python
parent1a98a89385a0ba89af7300de30e9abe2547e81ac (diff)
downloadmeta-openembedded-0c3d0146a4fb5004d47d333771d013c1c44baf22.tar.gz
python3-grpcio: Define -D_LARGEFILE64_SOURCE only for musl
On glibc this breaks build when using 64bit time_t since zlib ends up undefining _FILE_OFFSET_BITS when -D_LARGEFILE64_SOURCE is defined Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio_1.51.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.51.1.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.51.1.bb
index 9a3c3734a..b0971db1c 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio_1.51.1.bb
+++ b/meta-python/recipes-devtools/python/python3-grpcio_1.51.1.bb
@@ -22,7 +22,7 @@ RDEPENDS:${PN} = "${PYTHON_PN}-protobuf \
22inherit setuptools3 22inherit setuptools3
23inherit pypi 23inherit pypi
24 24
25CFLAGS += "-D_LARGEFILE64_SOURCE" 25CFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE"
26 26
27export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1" 27export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1"
28 28