diff options
author | Alexander Kanavin <alexander.kanavin@linux.intel.com> | 2017-05-05 17:09:11 +0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-05-23 15:49:35 +0200 |
commit | 04d5ee72720135e5f859b0a6a376408b3ac00dae (patch) | |
tree | 018985e8726991c95bc9d9c703310258f22df1f9 /meta-python | |
parent | a30e0f4cd336b6b84b0a203157bd8014370c9de6 (diff) | |
download | meta-openembedded-04d5ee72720135e5f859b0a6a376408b3ac00dae.tar.gz |
python-six: re-add the recipe for Python 2.x
python-six was removed from oe-core, so we should provide it in meta-oe.
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-six.inc | 18 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-six_1.10.0.bb | 2 |
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-six.inc b/meta-python/recipes-devtools/python/python-six.inc new file mode 100644 index 000000000..e33c01ded --- /dev/null +++ b/meta-python/recipes-devtools/python/python-six.inc | |||
@@ -0,0 +1,18 @@ | |||
1 | SUMMARY = "Python 2 and 3 compatibility library" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=6f00d4a50713fa859858dd9abaa35b21" | ||
4 | |||
5 | SRC_URI[md5sum] = "34eed507548117b2ab523ab14b2f8b55" | ||
6 | SRC_URI[sha256sum] = "105f8d68616f8248e24bf0e9372ef04d3cc10104f1980f54d57b2ce73a5ad56a" | ||
7 | |||
8 | do_compile_append() { | ||
9 | ${PYTHON} setup.py -q bdist_egg --dist-dir ./ | ||
10 | } | ||
11 | do_install_append() { | ||
12 | install -m 0644 ${S}/*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/ | ||
13 | } | ||
14 | |||
15 | RDEPENDS_${PN} += "${PYTHON_PN}-io" | ||
16 | |||
17 | BBCLASSEXTEND = "native nativesdk" | ||
18 | |||
diff --git a/meta-python/recipes-devtools/python/python-six_1.10.0.bb b/meta-python/recipes-devtools/python/python-six_1.10.0.bb new file mode 100644 index 000000000..9075745d7 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-six_1.10.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit pypi setuptools | ||
2 | require python-six.inc | ||