summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDominic Sacré <dominic.sacre@gmx.de>2015-08-24 17:27:53 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:17:07 +0200
commitb13250198de5e1a5461e3e8079cf858cc6a084a3 (patch)
tree38c31d1258057dd9efade90b32a3b4b463dd4d59 /meta-python
parenta7c72d7d7c3948081800ee118e5cd7ee2a146237 (diff)
downloadmeta-openembedded-b13250198de5e1a5461e3e8079cf858cc6a084a3.tar.gz
python3-lxml: Add new recipe
Use a common .inc file for the python-lxml and python3-lxml recipes. Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-lxml.inc31
-rw-r--r--meta-python/recipes-devtools/python/python-lxml_3.4.4.bb34
-rw-r--r--meta-python/recipes-devtools/python/python3-lxml_3.4.4.bb2
3 files changed, 34 insertions, 33 deletions
diff --git a/meta-python/recipes-devtools/python/python-lxml.inc b/meta-python/recipes-devtools/python/python-lxml.inc
new file mode 100644
index 000000000..9d1bfbcdc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-lxml.inc
@@ -0,0 +1,31 @@
1SUMMARY = "Python XML bindings for libxml2 and libxslt"
2DESCRIPTION = "Powerful and Pythonic XML processing library combining \
3libxml2/libxslt with the ElementTree API."
4HOMEPAGE = "http://codespeak.net/lxml"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=f9f1dc24f720c143c2240df41fe5073b"
7SRCNAME = "lxml"
8
9DEPENDS = "libxml2 libxslt"
10
11SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "a9a65972afc173ec7a39c585f4eea69c"
14SRC_URI[sha256sum] = "b3d362bac471172747cda3513238f115cbd6c5f8b8e6319bf6a97a7892724099"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18DISTUTILS_BUILD_ARGS += " \
19 --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
20 --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
21"
22
23DISTUTILS_INSTALL_ARGS += " \
24 --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
25 --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
26"
27
28BBCLASSEXTEND = "native nativesdk"
29
30RDEPENDS_${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
31RDEPENDS_${PN}_class-native = "libxml2-native libxslt-native"
diff --git a/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb b/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb
index 4fab4f3d5..81ccb12d8 100644
--- a/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb
+++ b/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb
@@ -1,34 +1,2 @@
1SUMMARY = "Python XML bindings for libxml2 and libxslt"
2DESCRIPTION = "Powerful and Pythonic XML processing library combining \
3libxml2/libxslt with the ElementTree API."
4HOMEPAGE = "http://codespeak.net/lxml"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=f9f1dc24f720c143c2240df41fe5073b"
7SRCNAME = "lxml"
8
9DEPENDS = "libxml2 libxslt"
10
11SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "a9a65972afc173ec7a39c585f4eea69c"
14SRC_URI[sha256sum] = "b3d362bac471172747cda3513238f115cbd6c5f8b8e6319bf6a97a7892724099"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit setuptools 1inherit setuptools
19 2require python-lxml.inc
20DISTUTILS_BUILD_ARGS += " \
21 --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
22 --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
23"
24
25DISTUTILS_INSTALL_ARGS += " \
26 --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
27 --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
28"
29
30BBCLASSEXTEND = "native nativesdk"
31
32RDEPENDS_${PN} += "libxml2 libxslt python-compression"
33RDEPENDS_${PN}_class-native = "libxml2-native libxslt-native"
34
diff --git a/meta-python/recipes-devtools/python/python3-lxml_3.4.4.bb b/meta-python/recipes-devtools/python/python3-lxml_3.4.4.bb
new file mode 100644
index 000000000..ff4bc7faa
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-lxml_3.4.4.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-lxml.inc