diff options
author | Derek Straka <derek@asterius.io> | 2018-01-21 11:20:37 -0500 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-01-26 17:28:12 -0800 |
commit | df997e0747decf536fc96f6c3be1adf3056f9f35 (patch) | |
tree | 44735f858b42e16fe1061b179f7f6563e229a0c2 /meta-python | |
parent | 49b6db7e66bbff7ec0c1ddbd746c656004527db5 (diff) | |
download | meta-openembedded-df997e0747decf536fc96f6c3be1adf3056f9f35.tar.gz |
Remove deprecated python3-subprocess from the RDEPENDS
The python3-subprocess package was merged into core as part of the
json manifest migration
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
48 files changed, 76 insertions, 38 deletions
diff --git a/meta-python/recipes-devtools/python/python-asn1crypto.inc b/meta-python/recipes-devtools/python/python-asn1crypto.inc index 2777c215b..5c379956f 100644 --- a/meta-python/recipes-devtools/python/python-asn1crypto.inc +++ b/meta-python/recipes-devtools/python/python-asn1crypto.inc | |||
@@ -18,7 +18,6 @@ RDEPENDS_${PN}_class-target += " \ | |||
18 | ${PYTHON_PN}-datetime \ | 18 | ${PYTHON_PN}-datetime \ |
19 | ${PYTHON_PN}-io \ | 19 | ${PYTHON_PN}-io \ |
20 | ${PYTHON_PN}-netclient \ | 20 | ${PYTHON_PN}-netclient \ |
21 | ${PYTHON_PN}-subprocess \ | ||
22 | " | 21 | " |
23 | 22 | ||
24 | BBCLASSEXTEND = "native" | 23 | BBCLASSEXTEND = "native" |
diff --git a/meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb b/meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb index 1218519ec..46aace286 100644 --- a/meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb +++ b/meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb | |||
@@ -2,5 +2,6 @@ inherit setuptools | |||
2 | require python-asn1crypto.inc | 2 | require python-asn1crypto.inc |
3 | 3 | ||
4 | RDEPENDS_${PN} += " \ | 4 | RDEPENDS_${PN} += " \ |
5 | ${PYTHON_PN}-subprocess \ | ||
5 | ${PYTHON_PN}-textutils \ | 6 | ${PYTHON_PN}-textutils \ |
6 | " | 7 | " |
diff --git a/meta-python/recipes-devtools/python/python-astroid.inc b/meta-python/recipes-devtools/python/python-astroid.inc index a71762c50..213dde532 100644 --- a/meta-python/recipes-devtools/python/python-astroid.inc +++ b/meta-python/recipes-devtools/python/python-astroid.inc | |||
@@ -20,7 +20,6 @@ RDEPENDS_${PN}_class-target += "\ | |||
20 | ${PYTHON_PN}-distutils \ | 20 | ${PYTHON_PN}-distutils \ |
21 | ${PYTHON_PN}-lazy-object-proxy \ | 21 | ${PYTHON_PN}-lazy-object-proxy \ |
22 | ${PYTHON_PN}-six \ | 22 | ${PYTHON_PN}-six \ |
23 | ${PYTHON_PN}-subprocess \ | ||
24 | ${PYTHON_PN}-wrapt \ | 23 | ${PYTHON_PN}-wrapt \ |
25 | ${PYTHON_PN}-setuptools \ | 24 | ${PYTHON_PN}-setuptools \ |
26 | " | 25 | " |
diff --git a/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb b/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb index fd98630e1..687394da6 100644 --- a/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb +++ b/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb | |||
@@ -6,4 +6,5 @@ RDEPENDS_${PN}_class-target += " \ | |||
6 | ${PYTHON_PN}-backports-functools-lru-cache \ | 6 | ${PYTHON_PN}-backports-functools-lru-cache \ |
7 | ${PYTHON_PN}-re \ | 7 | ${PYTHON_PN}-re \ |
8 | ${PYTHON_PN}-singledispatch \ | 8 | ${PYTHON_PN}-singledispatch \ |
9 | ${PYTHON_PN}-subprocess \ | ||
9 | " | 10 | " |
diff --git a/meta-python/recipes-devtools/python/python-attrs.inc b/meta-python/recipes-devtools/python/python-attrs.inc index ea8d3bf71..12410bf58 100644 --- a/meta-python/recipes-devtools/python/python-attrs.inc +++ b/meta-python/recipes-devtools/python/python-attrs.inc | |||
@@ -10,5 +10,4 @@ inherit pypi | |||
10 | 10 | ||
11 | RDEPENDS_${PN}_class-target += " \ | 11 | RDEPENDS_${PN}_class-target += " \ |
12 | ${PYTHON_PN}-ctypes \ | 12 | ${PYTHON_PN}-ctypes \ |
13 | ${PYTHON_PN}-subprocess \ | ||
14 | " | 13 | " |
diff --git a/meta-python/recipes-devtools/python/python-attrs_17.4.0.bb b/meta-python/recipes-devtools/python/python-attrs_17.4.0.bb index a6fdf158d..e3bec0fdf 100644 --- a/meta-python/recipes-devtools/python/python-attrs_17.4.0.bb +++ b/meta-python/recipes-devtools/python/python-attrs_17.4.0.bb | |||
@@ -1,2 +1,6 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools |
2 | require python-attrs.inc | 2 | require python-attrs.inc |
3 | |||
4 | RDEPENDS_${PN} += "\ | ||
5 | ${PYTHON_PN}-subprocess \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-babel.inc b/meta-python/recipes-devtools/python/python-babel.inc index b1e8cc1e9..4dcb255c8 100644 --- a/meta-python/recipes-devtools/python/python-babel.inc +++ b/meta-python/recipes-devtools/python/python-babel.inc | |||
@@ -21,6 +21,5 @@ RDEPENDS_${PN} += " \ | |||
21 | ${PYTHON_PN}-pickle \ | 21 | ${PYTHON_PN}-pickle \ |
22 | ${PYTHON_PN}-pytz \ | 22 | ${PYTHON_PN}-pytz \ |
23 | ${PYTHON_PN}-shell \ | 23 | ${PYTHON_PN}-shell \ |
24 | ${PYTHON_PN}-subprocess \ | ||
25 | ${PYTHON_PN}-threading \ | 24 | ${PYTHON_PN}-threading \ |
26 | " | 25 | " |
diff --git a/meta-python/recipes-devtools/python/python-babel_2.5.3.bb b/meta-python/recipes-devtools/python/python-babel_2.5.3.bb index e0eadcda8..f7c166eba 100644 --- a/meta-python/recipes-devtools/python/python-babel_2.5.3.bb +++ b/meta-python/recipes-devtools/python/python-babel_2.5.3.bb | |||
@@ -1,2 +1,6 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools |
2 | require python-babel.inc | 2 | require python-babel.inc |
3 | |||
4 | RDEPENDS_${PN} += " \ | ||
5 | ${PYTHON_PN}-subprocess \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-bcrypt.inc b/meta-python/recipes-devtools/python/python-bcrypt.inc index 3e6fa7a37..449096978 100644 --- a/meta-python/recipes-devtools/python/python-bcrypt.inc +++ b/meta-python/recipes-devtools/python/python-bcrypt.inc | |||
@@ -14,5 +14,4 @@ RDEPENDS_${PN}_class-target += "\ | |||
14 | ${PYTHON_PN}-ctypes \ | 14 | ${PYTHON_PN}-ctypes \ |
15 | ${PYTHON_PN}-shell \ | 15 | ${PYTHON_PN}-shell \ |
16 | ${PYTHON_PN}-six \ | 16 | ${PYTHON_PN}-six \ |
17 | ${PYTHON_PN}-subprocess \ | ||
18 | " | 17 | " |
diff --git a/meta-python/recipes-devtools/python/python-bcrypt_3.1.4.bb b/meta-python/recipes-devtools/python/python-bcrypt_3.1.4.bb index 24333540b..b136aa489 100644 --- a/meta-python/recipes-devtools/python/python-bcrypt_3.1.4.bb +++ b/meta-python/recipes-devtools/python/python-bcrypt_3.1.4.bb | |||
@@ -1,2 +1,6 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools |
2 | require python-bcrypt.inc | 2 | require python-bcrypt.inc |
3 | |||
4 | RDEPENDS_${PN} += "\ | ||
5 | ${PYTHON_PN}-subprocess \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-can.inc b/meta-python/recipes-devtools/python/python-can.inc index 2b15af40a..70cde19e5 100644 --- a/meta-python/recipes-devtools/python/python-can.inc +++ b/meta-python/recipes-devtools/python/python-can.inc | |||
@@ -13,6 +13,5 @@ RDEPENDS_${PN}_class-target += "\ | |||
13 | ${PYTHON_PN}-logging \ | 13 | ${PYTHON_PN}-logging \ |
14 | ${PYTHON_PN}-misc \ | 14 | ${PYTHON_PN}-misc \ |
15 | ${PYTHON_PN}-netserver \ | 15 | ${PYTHON_PN}-netserver \ |
16 | ${PYTHON_PN}-subprocess \ | ||
17 | ${PYTHON_PN}-sqlite3 \ | 16 | ${PYTHON_PN}-sqlite3 \ |
18 | " | 17 | " |
diff --git a/meta-python/recipes-devtools/python/python-can_2.0.0.bb b/meta-python/recipes-devtools/python/python-can_2.0.0.bb index fcfde2f63..f0edb6408 100644 --- a/meta-python/recipes-devtools/python/python-can_2.0.0.bb +++ b/meta-python/recipes-devtools/python/python-can_2.0.0.bb | |||
@@ -3,5 +3,6 @@ inherit pypi setuptools | |||
3 | 3 | ||
4 | RDEPENDS_${PN}_class-target += "\ | 4 | RDEPENDS_${PN}_class-target += "\ |
5 | ${PYTHON_PN}-argparse \ | 5 | ${PYTHON_PN}-argparse \ |
6 | ${PYTHON_PN}-subprocess \ | ||
6 | ${PYTHON_PN}-zlib \ | 7 | ${PYTHON_PN}-zlib \ |
7 | " | 8 | " |
diff --git a/meta-python/recipes-devtools/python/python-cffi.inc b/meta-python/recipes-devtools/python/python-cffi.inc index 9c934b2f0..39ab19ff8 100644 --- a/meta-python/recipes-devtools/python/python-cffi.inc +++ b/meta-python/recipes-devtools/python/python-cffi.inc | |||
@@ -11,7 +11,6 @@ RDEPENDS_${PN}_class-target = " \ | |||
11 | ${PYTHON_PN}-ctypes \ | 11 | ${PYTHON_PN}-ctypes \ |
12 | ${PYTHON_PN}-io \ | 12 | ${PYTHON_PN}-io \ |
13 | ${PYTHON_PN}-shell \ | 13 | ${PYTHON_PN}-shell \ |
14 | ${PYTHON_PN}-subprocess \ | ||
15 | " | 14 | " |
16 | 15 | ||
17 | BBCLASSEXTEND = "native nativesdk" | 16 | BBCLASSEXTEND = "native nativesdk" |
diff --git a/meta-python/recipes-devtools/python/python-cffi_1.11.4.bb b/meta-python/recipes-devtools/python/python-cffi_1.11.4.bb index 3cd62d1f7..bc667b805 100644 --- a/meta-python/recipes-devtools/python/python-cffi_1.11.4.bb +++ b/meta-python/recipes-devtools/python/python-cffi_1.11.4.bb | |||
@@ -1,2 +1,6 @@ | |||
1 | require python-cffi.inc | 1 | require python-cffi.inc |
2 | inherit pypi setuptools | 2 | inherit pypi setuptools |
3 | |||
4 | RDEPENDS_${PN} += " \ | ||
5 | ${PYTHON_PN}-subprocess \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-cryptography.inc b/meta-python/recipes-devtools/python/python-cryptography.inc index 80d6b0a3b..4be79077e 100644 --- a/meta-python/recipes-devtools/python/python-cryptography.inc +++ b/meta-python/recipes-devtools/python/python-cryptography.inc | |||
@@ -28,7 +28,6 @@ RDEPENDS_${PN}_class-target += " \ | |||
28 | ${PYTHON_PN}-numbers \ | 28 | ${PYTHON_PN}-numbers \ |
29 | ${PYTHON_PN}-asn1crypto \ | 29 | ${PYTHON_PN}-asn1crypto \ |
30 | ${PYTHON_PN}-pycparser \ | 30 | ${PYTHON_PN}-pycparser \ |
31 | ${PYTHON_PN}-subprocess \ | ||
32 | ${PYTHON_PN}-setuptools \ | 31 | ${PYTHON_PN}-setuptools \ |
33 | ${PYTHON_PN}-six \ | 32 | ${PYTHON_PN}-six \ |
34 | ${PYTHON_PN}-threading \ | 33 | ${PYTHON_PN}-threading \ |
diff --git a/meta-python/recipes-devtools/python/python-cryptography_2.1.4.bb b/meta-python/recipes-devtools/python/python-cryptography_2.1.4.bb index f5b1e0b3b..9c2f88418 100644 --- a/meta-python/recipes-devtools/python/python-cryptography_2.1.4.bb +++ b/meta-python/recipes-devtools/python/python-cryptography_2.1.4.bb | |||
@@ -18,4 +18,5 @@ RDEPENDS_${PN}_class-target += " \ | |||
18 | ${PYTHON_PN}-enum34 \ | 18 | ${PYTHON_PN}-enum34 \ |
19 | ${PYTHON_PN}-ipaddress \ | 19 | ${PYTHON_PN}-ipaddress \ |
20 | ${PYTHON_PN}-contextlib \ | 20 | ${PYTHON_PN}-contextlib \ |
21 | ${PYTHON_PN}-subprocess \ | ||
21 | " | 22 | " |
diff --git a/meta-python/recipes-devtools/python/python-cython.inc b/meta-python/recipes-devtools/python/python-cython.inc index 8d8f27c02..6e424a90c 100644 --- a/meta-python/recipes-devtools/python/python-cython.inc +++ b/meta-python/recipes-devtools/python/python-cython.inc | |||
@@ -14,7 +14,6 @@ inherit pypi | |||
14 | 14 | ||
15 | RDEPENDS_${PN}_class-target += "\ | 15 | RDEPENDS_${PN}_class-target += "\ |
16 | ${PYTHON_PN}-netserver \ | 16 | ${PYTHON_PN}-netserver \ |
17 | ${PYTHON_PN}-subprocess \ | ||
18 | ${PYTHON_PN}-shell \ | 17 | ${PYTHON_PN}-shell \ |
19 | " | 18 | " |
20 | 19 | ||
diff --git a/meta-python/recipes-devtools/python/python-cython_0.27.3.bb b/meta-python/recipes-devtools/python/python-cython_0.27.3.bb index bdf9490c6..d803a6ed4 100644 --- a/meta-python/recipes-devtools/python/python-cython_0.27.3.bb +++ b/meta-python/recipes-devtools/python/python-cython_0.27.3.bb | |||
@@ -5,5 +5,6 @@ UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/Cython/" | |||
5 | UPSTREAM_CHECK_REGEX = "/Cython/(?P<pver>(\d+[\.\-_]*)+)" | 5 | UPSTREAM_CHECK_REGEX = "/Cython/(?P<pver>(\d+[\.\-_]*)+)" |
6 | 6 | ||
7 | RDEPENDS_${PN} += "\ | 7 | RDEPENDS_${PN} += "\ |
8 | python-distribute \ | 8 | ${PYTHON_PN}-distribute \ |
9 | ${PYTHON_PN}-subprocess \ | ||
9 | " | 10 | " |
diff --git a/meta-python/recipes-devtools/python/python-django.inc b/meta-python/recipes-devtools/python/python-django.inc index 3602a74aa..ac0808eef 100644 --- a/meta-python/recipes-devtools/python/python-django.inc +++ b/meta-python/recipes-devtools/python/python-django.inc | |||
@@ -25,7 +25,6 @@ RDEPENDS_${PN} += "\ | |||
25 | ${PYTHON_PN}-numbers \ | 25 | ${PYTHON_PN}-numbers \ |
26 | ${PYTHON_PN}-pkgutil \ | 26 | ${PYTHON_PN}-pkgutil \ |
27 | ${PYTHON_PN}-pytz \ | 27 | ${PYTHON_PN}-pytz \ |
28 | ${PYTHON_PN}-subprocess \ | ||
29 | ${PYTHON_PN}-threading \ | 28 | ${PYTHON_PN}-threading \ |
30 | ${PYTHON_PN}-unixadmin \ | 29 | ${PYTHON_PN}-unixadmin \ |
31 | ${PYTHON_PN}-xml \ | 30 | ${PYTHON_PN}-xml \ |
diff --git a/meta-python/recipes-devtools/python/python-django_1.11.9.bb b/meta-python/recipes-devtools/python/python-django_1.11.9.bb index db48ffdd7..d2347cc96 100644 --- a/meta-python/recipes-devtools/python/python-django_1.11.9.bb +++ b/meta-python/recipes-devtools/python/python-django_1.11.9.bb | |||
@@ -1,4 +1,8 @@ | |||
1 | require python-django.inc | 1 | require python-django.inc |
2 | inherit setuptools | 2 | inherit setuptools |
3 | 3 | ||
4 | RDEPENDS_${PN} += "${PYTHON_PN}-argparse ${PYTHON_PN}-zlib" | 4 | RDEPENDS_${PN} += " \ |
5 | ${PYTHON_PN}-argparse \ | ||
6 | ${PYTHON_PN}-subprocess \ | ||
7 | ${PYTHON_PN}-zlib \ | ||
8 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-jsonschema.inc b/meta-python/recipes-devtools/python/python-jsonschema.inc index 841369292..6fdc02498 100644 --- a/meta-python/recipes-devtools/python/python-jsonschema.inc +++ b/meta-python/recipes-devtools/python/python-jsonschema.inc | |||
@@ -18,7 +18,6 @@ RDEPENDS_${PN} += " \ | |||
18 | ${PYTHON_PN}-rfc3987 \ | 18 | ${PYTHON_PN}-rfc3987 \ |
19 | ${PYTHON_PN}-shell \ | 19 | ${PYTHON_PN}-shell \ |
20 | ${PYTHON_PN}-strict-rfc3339 \ | 20 | ${PYTHON_PN}-strict-rfc3339 \ |
21 | ${PYTHON_PN}-subprocess \ | ||
22 | ${PYTHON_PN}-unittest \ | 21 | ${PYTHON_PN}-unittest \ |
23 | " | 22 | " |
24 | 23 | ||
diff --git a/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb b/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb index 740761633..b677c646e 100644 --- a/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb +++ b/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb | |||
@@ -7,5 +7,6 @@ RDEPENDS_${PN} += " \ | |||
7 | ${PYTHON_PN}-functools32 \ | 7 | ${PYTHON_PN}-functools32 \ |
8 | ${PYTHON_PN}-lang \ | 8 | ${PYTHON_PN}-lang \ |
9 | ${PYTHON_PN}-re \ | 9 | ${PYTHON_PN}-re \ |
10 | ${PYTHON_PN}-subprocess \ | ||
10 | ${PYTHON_PN}-textutils \ | 11 | ${PYTHON_PN}-textutils \ |
11 | " | 12 | " |
diff --git a/meta-python/recipes-devtools/python/python-paho-mqtt.inc b/meta-python/recipes-devtools/python/python-paho-mqtt.inc index 6459e68b4..23169165f 100644 --- a/meta-python/recipes-devtools/python/python-paho-mqtt.inc +++ b/meta-python/recipes-devtools/python/python-paho-mqtt.inc | |||
@@ -13,9 +13,8 @@ SRC_URI[sha256sum] = "31911f6031de306c27ed79dc77b690d7c55b0dcb0f0434ca34ec6361d0 | |||
13 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" | 13 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" |
14 | 14 | ||
15 | RDEPENDS_${PN} = "\ | 15 | RDEPENDS_${PN} = "\ |
16 | ${PYTHON_PN}-math \ | 16 | ${PYTHON_PN}-math \ |
17 | ${PYTHON_PN}-io \ | 17 | ${PYTHON_PN}-io \ |
18 | ${PYTHON_PN}-netclient \ | 18 | ${PYTHON_PN}-netclient \ |
19 | ${PYTHON_PN}-threading \ | 19 | ${PYTHON_PN}-threading \ |
20 | ${PYTHON_PN}-subprocess \ | ||
21 | " | 20 | " |
diff --git a/meta-python/recipes-devtools/python/python-paho-mqtt_1.3.1.bb b/meta-python/recipes-devtools/python/python-paho-mqtt_1.3.1.bb index f369b2e84..a1031176e 100644 --- a/meta-python/recipes-devtools/python/python-paho-mqtt_1.3.1.bb +++ b/meta-python/recipes-devtools/python/python-paho-mqtt_1.3.1.bb | |||
@@ -1,3 +1,6 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools |
2 | require python-paho-mqtt.inc | 2 | require python-paho-mqtt.inc |
3 | 3 | ||
4 | RDEPENDS_${PN} += " \ | ||
5 | ${PYTHON_PN}-subprocess \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-prompt-toolkit.inc b/meta-python/recipes-devtools/python/python-prompt-toolkit.inc index f5ed349f2..cc409a4eb 100644 --- a/meta-python/recipes-devtools/python/python-prompt-toolkit.inc +++ b/meta-python/recipes-devtools/python/python-prompt-toolkit.inc | |||
@@ -10,7 +10,6 @@ PYPI_PACKAGE = "prompt_toolkit" | |||
10 | RDEPENDS_${PN} += " \ | 10 | RDEPENDS_${PN} += " \ |
11 | ${PYTHON_PN}-core \ | 11 | ${PYTHON_PN}-core \ |
12 | ${PYTHON_PN}-six \ | 12 | ${PYTHON_PN}-six \ |
13 | ${PYTHON_PN}-subprocess \ | ||
14 | ${PYTHON_PN}-terminal \ | 13 | ${PYTHON_PN}-terminal \ |
15 | ${PYTHON_PN}-threading \ | 14 | ${PYTHON_PN}-threading \ |
16 | ${PYTHON_PN}-wcwidth \ | 15 | ${PYTHON_PN}-wcwidth \ |
diff --git a/meta-python/recipes-devtools/python/python-prompt-toolkit_1.0.15.bb b/meta-python/recipes-devtools/python/python-prompt-toolkit_1.0.15.bb index 76e841014..527c905a8 100644 --- a/meta-python/recipes-devtools/python/python-prompt-toolkit_1.0.15.bb +++ b/meta-python/recipes-devtools/python/python-prompt-toolkit_1.0.15.bb | |||
@@ -1,2 +1,6 @@ | |||
1 | inherit pypi setuptools | 1 | inherit pypi setuptools |
2 | require python-prompt-toolkit.inc | 2 | require python-prompt-toolkit.inc |
3 | |||
4 | RDEPENDS_${PN} += " \ | ||
5 | ${PYTHON_PN}-subprocess \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-psutil.inc b/meta-python/recipes-devtools/python/python-psutil.inc index b96d54f3f..5d8e61f4b 100644 --- a/meta-python/recipes-devtools/python/python-psutil.inc +++ b/meta-python/recipes-devtools/python/python-psutil.inc | |||
@@ -15,7 +15,6 @@ FILES_${PN}-tests += " \ | |||
15 | 15 | ||
16 | RDEPENDS_${PN} += " \ | 16 | RDEPENDS_${PN} += " \ |
17 | ${PYTHON_PN}-shell \ | 17 | ${PYTHON_PN}-shell \ |
18 | ${PYTHON_PN}-subprocess \ | ||
19 | ${PYTHON_PN}-threading \ | 18 | ${PYTHON_PN}-threading \ |
20 | ${PYTHON_PN}-xml \ | 19 | ${PYTHON_PN}-xml \ |
21 | " | 20 | " |
diff --git a/meta-python/recipes-devtools/python/python-psutil_5.4.3.bb b/meta-python/recipes-devtools/python/python-psutil_5.4.3.bb index bf402aa47..9aabfb206 100644 --- a/meta-python/recipes-devtools/python/python-psutil_5.4.3.bb +++ b/meta-python/recipes-devtools/python/python-psutil_5.4.3.bb | |||
@@ -1,2 +1,6 @@ | |||
1 | inherit pypi setuptools | 1 | inherit pypi setuptools |
2 | require python-psutil.inc | 2 | require python-psutil.inc |
3 | |||
4 | RDEPENDS_${PN} += " \ | ||
5 | ${PYTHON_PN}-subprocess \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-pycparser.inc b/meta-python/recipes-devtools/python/python-pycparser.inc index f445a2093..d112d9f77 100644 --- a/meta-python/recipes-devtools/python/python-pycparser.inc +++ b/meta-python/recipes-devtools/python/python-pycparser.inc | |||
@@ -11,7 +11,6 @@ BBCLASSEXTEND = "native nativesdk" | |||
11 | RDEPENDS_${PN}_class-target += "\ | 11 | RDEPENDS_${PN}_class-target += "\ |
12 | ${PYTHON_PN}-ply \ | 12 | ${PYTHON_PN}-ply \ |
13 | ${PYTHON_PN}-pprint \ | 13 | ${PYTHON_PN}-pprint \ |
14 | ${PYTHON_PN}-subprocess \ | ||
15 | cpp \ | 14 | cpp \ |
16 | cpp-symlinks \ | 15 | cpp-symlinks \ |
17 | " | 16 | " |
diff --git a/meta-python/recipes-devtools/python/python-pycparser_2.18.bb b/meta-python/recipes-devtools/python/python-pycparser_2.18.bb index adbc1a8f4..98742737f 100644 --- a/meta-python/recipes-devtools/python/python-pycparser_2.18.bb +++ b/meta-python/recipes-devtools/python/python-pycparser_2.18.bb | |||
@@ -1,2 +1,6 @@ | |||
1 | inherit pypi setuptools | 1 | inherit pypi setuptools |
2 | require python-pycparser.inc | 2 | require python-pycparser.inc |
3 | |||
4 | RDEPENDS_${PN} += " \ | ||
5 | ${PYTHON_PN}-subprocess \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-pyinotify.inc b/meta-python/recipes-devtools/python/python-pyinotify.inc index 7fcbb1850..975f11c10 100644 --- a/meta-python/recipes-devtools/python/python-pyinotify.inc +++ b/meta-python/recipes-devtools/python/python-pyinotify.inc | |||
@@ -5,7 +5,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ab173cade7965b411528464589a08382" | |||
5 | RDEPENDS_${PN} += "\ | 5 | RDEPENDS_${PN} += "\ |
6 | ${PYTHON_PN}-threading \ | 6 | ${PYTHON_PN}-threading \ |
7 | ${PYTHON_PN}-io \ | 7 | ${PYTHON_PN}-io \ |
8 | ${PYTHON_PN}-subprocess \ | ||
9 | ${PYTHON_PN}-misc \ | 8 | ${PYTHON_PN}-misc \ |
10 | ${PYTHON_PN}-shell \ | 9 | ${PYTHON_PN}-shell \ |
11 | " | 10 | " |
diff --git a/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb b/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb index d1f84c3ca..0c9a2c72e 100644 --- a/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb +++ b/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb | |||
@@ -1,2 +1,6 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools |
2 | require python-pyinotify.inc | 2 | require python-pyinotify.inc |
3 | |||
4 | RDEPENDS_${PN} += "\ | ||
5 | ${PYTHON_PN}-subprocess \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-pyperclip.inc b/meta-python/recipes-devtools/python/python-pyperclip.inc index c712fdd7c..e05de6723 100644 --- a/meta-python/recipes-devtools/python/python-pyperclip.inc +++ b/meta-python/recipes-devtools/python/python-pyperclip.inc | |||
@@ -9,5 +9,4 @@ inherit pypi | |||
9 | 9 | ||
10 | RDEPENDS_${PN} += " \ | 10 | RDEPENDS_${PN} += " \ |
11 | ${PYTHON_PN}-ctypes \ | 11 | ${PYTHON_PN}-ctypes \ |
12 | ${PYTHON_PN}-subprocess \ | ||
13 | " | 12 | " |
diff --git a/meta-python/recipes-devtools/python/python-pyperclip_1.6.0.bb b/meta-python/recipes-devtools/python/python-pyperclip_1.6.0.bb index 6e93b8179..6c9fcbd84 100644 --- a/meta-python/recipes-devtools/python/python-pyperclip_1.6.0.bb +++ b/meta-python/recipes-devtools/python/python-pyperclip_1.6.0.bb | |||
@@ -1,4 +1,7 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools |
2 | require python-pyperclip.inc | 2 | require python-pyperclip.inc |
3 | 3 | ||
4 | RDEPENDS_${PN} += "${PYTHON_PN}-contextlib" | 4 | RDEPENDS_${PN} += " \ |
5 | ${PYTHON_PN}-contextlib \ | ||
6 | ${PYTHON_PN}-subprocess \ | ||
7 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-pyroute2.inc b/meta-python/recipes-devtools/python/python-pyroute2.inc index 24e3555c7..f7b57d9e4 100644 --- a/meta-python/recipes-devtools/python/python-pyroute2.inc +++ b/meta-python/recipes-devtools/python/python-pyroute2.inc | |||
@@ -19,6 +19,5 @@ RDEPENDS_${PN} += " \ | |||
19 | ${PYTHON_PN}-pkgutil \ | 19 | ${PYTHON_PN}-pkgutil \ |
20 | ${PYTHON_PN}-pprint \ | 20 | ${PYTHON_PN}-pprint \ |
21 | ${PYTHON_PN}-shell \ | 21 | ${PYTHON_PN}-shell \ |
22 | ${PYTHON_PN}-subprocess \ | ||
23 | ${PYTHON_PN}-unixadmin \ | 22 | ${PYTHON_PN}-unixadmin \ |
24 | " | 23 | " |
diff --git a/meta-python/recipes-devtools/python/python-pyroute2_0.4.21.bb b/meta-python/recipes-devtools/python/python-pyroute2_0.4.21.bb index 7b9c8e044..f25f1b4ab 100644 --- a/meta-python/recipes-devtools/python/python-pyroute2_0.4.21.bb +++ b/meta-python/recipes-devtools/python/python-pyroute2_0.4.21.bb | |||
@@ -1,2 +1,6 @@ | |||
1 | require python-pyroute2.inc | 1 | require python-pyroute2.inc |
2 | inherit setuptools | 2 | inherit setuptools |
3 | |||
4 | RDEPENDS_${PN} += "\ | ||
5 | ${PYTHON_PN}-subprocess \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-pyudev.inc b/meta-python/recipes-devtools/python/python-pyudev.inc index ab4c5fd7d..cb906c9ec 100644 --- a/meta-python/recipes-devtools/python/python-pyudev.inc +++ b/meta-python/recipes-devtools/python/python-pyudev.inc | |||
@@ -14,6 +14,5 @@ RDEPENDS_${PN} = "\ | |||
14 | ${PYTHON_PN}-ctypes \ | 14 | ${PYTHON_PN}-ctypes \ |
15 | ${PYTHON_PN}-misc \ | 15 | ${PYTHON_PN}-misc \ |
16 | ${PYTHON_PN}-six \ | 16 | ${PYTHON_PN}-six \ |
17 | ${PYTHON_PN}-subprocess \ | ||
18 | ${PYTHON_PN}-threading \ | 17 | ${PYTHON_PN}-threading \ |
19 | " | 18 | " |
diff --git a/meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb b/meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb index 32573b7a0..a3e15014a 100644 --- a/meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb +++ b/meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb | |||
@@ -2,6 +2,7 @@ require python-pyudev.inc | |||
2 | 2 | ||
3 | RDEPENDS_${PN} = "\ | 3 | RDEPENDS_${PN} = "\ |
4 | ${PYTHON_PN}-contextlib \ | 4 | ${PYTHON_PN}-contextlib \ |
5 | ${PYTHON_PN}-subprocess \ | ||
5 | " | 6 | " |
6 | 7 | ||
7 | inherit pypi setuptools | 8 | inherit pypi setuptools |
diff --git a/meta-python/recipes-devtools/python/python-tornado.inc b/meta-python/recipes-devtools/python/python-tornado.inc index b9a99c792..7cf6dc5e0 100644 --- a/meta-python/recipes-devtools/python/python-tornado.inc +++ b/meta-python/recipes-devtools/python/python-tornado.inc | |||
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://setup.py;startline=2;endline=15;md5=5ab7571a79ad62d0c | |||
9 | SRC_URI[md5sum] = "a5fc7fd4aea94867609a491ce65786f1" | 9 | SRC_URI[md5sum] = "a5fc7fd4aea94867609a491ce65786f1" |
10 | SRC_URI[sha256sum] = "6d14e47eab0e15799cf3cdcc86b0b98279da68522caace2bd7ce644287685f0a" | 10 | SRC_URI[sha256sum] = "6d14e47eab0e15799cf3cdcc86b0b98279da68522caace2bd7ce644287685f0a" |
11 | 11 | ||
12 | RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email ${PYTHON_PN}-subprocess \ | 12 | RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email \ |
13 | ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi ${PYTHON_PN}-threading \ | 13 | ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi ${PYTHON_PN}-threading \ |
14 | ${PYTHON_PN}-ctypes" | 14 | ${PYTHON_PN}-ctypes" |
15 | 15 | ||
diff --git a/meta-python/recipes-devtools/python/python-tornado_4.5.3.bb b/meta-python/recipes-devtools/python/python-tornado_4.5.3.bb index 5d1147556..193a4db7d 100644 --- a/meta-python/recipes-devtools/python/python-tornado_4.5.3.bb +++ b/meta-python/recipes-devtools/python/python-tornado_4.5.3.bb | |||
@@ -1,3 +1,8 @@ | |||
1 | inherit pypi setuptools | 1 | inherit pypi setuptools |
2 | require python-tornado.inc | 2 | require python-tornado.inc |
3 | RDEPENDS_${PN} += "${PYTHON_PN}-backports-ssl ${PYTHON_PN}-backports-abc ${PYTHON_PN}-singledispatch" | 3 | RDEPENDS_${PN} += " \ |
4 | ${PYTHON_PN}-backports-abc \ | ||
5 | ${PYTHON_PN}-backports-ssl \ | ||
6 | ${PYTHON_PN}-singledispatch \ | ||
7 | ${PYTHON_PN}-subprocess \ | ||
8 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-werkzeug.inc b/meta-python/recipes-devtools/python/python-werkzeug.inc index 5e6003f20..c04a4e0c4 100644 --- a/meta-python/recipes-devtools/python/python-werkzeug.inc +++ b/meta-python/recipes-devtools/python/python-werkzeug.inc | |||
@@ -37,7 +37,6 @@ RDEPENDS_${PN} += " \ | |||
37 | ${PYTHON_PN}-numbers \ | 37 | ${PYTHON_PN}-numbers \ |
38 | ${PYTHON_PN}-pkgutil \ | 38 | ${PYTHON_PN}-pkgutil \ |
39 | ${PYTHON_PN}-pprint \ | 39 | ${PYTHON_PN}-pprint \ |
40 | ${PYTHON_PN}-subprocess \ | ||
41 | ${PYTHON_PN}-threading \ | 40 | ${PYTHON_PN}-threading \ |
42 | ${PYTHON_PN}-unixadmin \ | 41 | ${PYTHON_PN}-unixadmin \ |
43 | " | 42 | " |
diff --git a/meta-python/recipes-devtools/python/python-werkzeug_0.14.1.bb b/meta-python/recipes-devtools/python/python-werkzeug_0.14.1.bb index 3892f1357..db41161b3 100644 --- a/meta-python/recipes-devtools/python/python-werkzeug_0.14.1.bb +++ b/meta-python/recipes-devtools/python/python-werkzeug_0.14.1.bb | |||
@@ -1,4 +1,7 @@ | |||
1 | inherit pypi setuptools | 1 | inherit pypi setuptools |
2 | require python-werkzeug.inc | 2 | require python-werkzeug.inc |
3 | 3 | ||
4 | RDEPENDS_${PN} += "${PYTHON_PN}-zlib" | 4 | RDEPENDS_${PN} += " \ |
5 | ${PYTHON_PN}-subprocess \ | ||
6 | ${PYTHON_PN}-zlib \ | ||
7 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-whoosh.inc b/meta-python/recipes-devtools/python/python-whoosh.inc index f43d8c1b0..a4ca5dcd4 100644 --- a/meta-python/recipes-devtools/python/python-whoosh.inc +++ b/meta-python/recipes-devtools/python/python-whoosh.inc | |||
@@ -21,5 +21,4 @@ RDEPENDS_${PN} += " \ | |||
21 | ${PYTHON_PN}-pickle \ | 21 | ${PYTHON_PN}-pickle \ |
22 | ${PYTHON_PN}-shell \ | 22 | ${PYTHON_PN}-shell \ |
23 | ${PYTHON_PN}-stringold \ | 23 | ${PYTHON_PN}-stringold \ |
24 | ${PYTHON_PN}-subprocess \ | ||
25 | " | 24 | " |
diff --git a/meta-python/recipes-devtools/python/python-whoosh_2.7.4.bb b/meta-python/recipes-devtools/python/python-whoosh_2.7.4.bb index 48df36017..3b4291f40 100644 --- a/meta-python/recipes-devtools/python/python-whoosh_2.7.4.bb +++ b/meta-python/recipes-devtools/python/python-whoosh_2.7.4.bb | |||
@@ -1,2 +1,6 @@ | |||
1 | inherit pypi setuptools | 1 | inherit pypi setuptools |
2 | require python-whoosh.inc | 2 | require python-whoosh.inc |
3 | |||
4 | RDEPENDS_${PN} += " \ | ||
5 | ${PYTHON_PN}-subprocess \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb b/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb index e6e972617..415ca9f2e 100644 --- a/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb +++ b/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb | |||
@@ -4,5 +4,4 @@ require python-pymongo.inc | |||
4 | # Requires _pydecimal which is in misc | 4 | # Requires _pydecimal which is in misc |
5 | RDEPENDS_${PYTHON_PN}-bson += " \ | 5 | RDEPENDS_${PYTHON_PN}-bson += " \ |
6 | ${PYTHON_PN}-misc \ | 6 | ${PYTHON_PN}-misc \ |
7 | ${PYTHON_PN}-subprocess \ | ||
8 | " | 7 | " |
diff --git a/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb b/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb index 189a65a98..f6372c8d5 100644 --- a/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb +++ b/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb | |||
@@ -17,8 +17,4 @@ do_install_append() { | |||
17 | install -m 0644 ${S}/vcversioner*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/ | 17 | install -m 0644 ${S}/vcversioner*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/ |
18 | } | 18 | } |
19 | 19 | ||
20 | RDEPENDS_${PN} += "\ | ||
21 | ${PYTHON_PN}-subprocess \ | ||
22 | " | ||
23 | |||
24 | BBCLASSEXTEND = "native" | 20 | BBCLASSEXTEND = "native" |
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted.inc b/meta-python/recipes-extended/python-pyparted/python-pyparted.inc index c82909d10..a0ec02817 100644 --- a/meta-python/recipes-extended/python-pyparted/python-pyparted.inc +++ b/meta-python/recipes-extended/python-pyparted/python-pyparted.inc | |||
@@ -18,6 +18,5 @@ S = "${WORKDIR}/git" | |||
18 | 18 | ||
19 | RDEPENDS_${PN}_class-target += " \ | 19 | RDEPENDS_${PN}_class-target += " \ |
20 | parted (>= 2.3) \ | 20 | parted (>= 2.3) \ |
21 | ${PYTHON_PN}-subprocess \ | ||
22 | " | 21 | " |
23 | RDEPENDS_${PN}_class-native = "" | 22 | RDEPENDS_${PN}_class-native = "" |
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb index 81d61c62a..7d00fd7d9 100644 --- a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb +++ b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb | |||
@@ -4,7 +4,7 @@ PV = "3.10.7+git${SRCPV}" | |||
4 | 4 | ||
5 | inherit distutils | 5 | inherit distutils |
6 | 6 | ||
7 | RDEPENDS_${PN} += "python-stringold python-codecs python-math" | 7 | RDEPENDS_${PN} += "python-stringold python-codecs python-math python-subprocess" |
8 | RDEPENDS_${PN}_class-native = "" | 8 | RDEPENDS_${PN}_class-native = "" |
9 | 9 | ||
10 | BBCLASSEXTEND = "native" | 10 | BBCLASSEXTEND = "native" |