summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2021-07-16 09:27:36 -0400
committerKhem Raj <raj.khem@gmail.com>2021-07-20 09:27:56 -0700
commitcd80092d94fa65f1a6501b00d9a5e567d9887181 (patch)
tree7a9e0f14b9957481ba0de90f157129156da50e9c /meta-python
parent95e9269af694d5e102cc30bedd2ac36af53072ae (diff)
downloadmeta-openembedded-cd80092d94fa65f1a6501b00d9a5e567d9887181.tar.gz
python3-geomet: add recipe
GeoMet - Convert GeoJSON to WKT/WKB, and vice versa Release 0.3.0 notes: - Add support for GeoPackage binary format (#56) - Add support for EsriJSON (#63, #66) - Migrate CI/CD/release automation to CircleCI, away from - Travis-CI (#62) - Automate releases to PyPI through CircleCI (#62, #67) - Fix parsing for empty geometries (#53, #49) - Improve test coverage (#54) Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-geomet_0.3.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-geomet_0.3.0.bb b/meta-python/recipes-devtools/python/python3-geomet_0.3.0.bb
new file mode 100644
index 000000000..bf2db495c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-geomet_0.3.0.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Convert GeoJSON to WKT/WKB (Well-Known Text/Binary), and vice versa."
2DESCRIPTION = "Convert GeoJSON to WKT/WKB (Well-Known Text/Binary), and vice versa."
3HOMEPAGE = "https://github.com/geomet/geomet"
4SECTION = "devel/python"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
7SRCNAME = "geomet"
8
9SRC_URI[sha256sum] = "cb52411978ee01ff104ab48f108d7333b14423ae7a15a65fee25b7d29bda2e1b"
10
11S = "${WORKDIR}/git"
12SRC_URI = "git://github.com/geomet/geomet.git;protocol=https;branch=release-${PV} \
13 "
14SRCREV = "73ec5ec96cca32f2e2461d3964fc3d4ab80248f9"
15
16inherit setuptools3
17
18RDEPENDS_${PN} += "\
19 ${PYTHON_PN}-click \
20 ${PYTHON_PN}-six \
21"