diff options
author | Jack Mitchell <ml@embed.me.uk> | 2020-08-18 09:52:15 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-08-19 14:03:16 -0700 |
commit | b04b6048f276cc4c755d0503ff59835933fb60c4 (patch) | |
tree | 632b8482154bfaffe74f9d24dababd115d6a3400 /meta-python | |
parent | 0b22ed995fec7ee23c23a9eed8323685af1e1403 (diff) | |
download | meta-openembedded-b04b6048f276cc4c755d0503ff59835933fb60c4.tar.gz |
python3-pybind11: install both python wheel and cmake build
The wheel for this module doesn't install the required cmake
files, yet the cmake build doesn't install the required
python module files. Therefore use manual calls to the cmake
and distutils classes in order to get both into the final
package. This method is also what other popular distros use
such as Archlinux.
Signed-off-by: Jack Mitchell <ml@embed.me.uk>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb | 16 |
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb index 46bba8d8d..9674ec093 100644 --- a/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb +++ b/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb | |||
@@ -17,4 +17,18 @@ BBCLASSEXTEND = "native" | |||
17 | 17 | ||
18 | EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF" | 18 | EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF" |
19 | 19 | ||
20 | inherit cmake python3native | 20 | inherit cmake setuptools3 python3native |
21 | |||
22 | do_configure() { | ||
23 | cmake_do_configure | ||
24 | } | ||
25 | |||
26 | do_compile() { | ||
27 | distutils3_do_compile | ||
28 | cmake_do_compile | ||
29 | } | ||
30 | |||
31 | do_install() { | ||
32 | distutils3_do_install | ||
33 | cmake_do_install | ||
34 | } | ||