summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:12:36 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commitb00888a0a6bd5e7ea3c648dd12d1836196e66a6f (patch)
tree92ad52bbc5ea4dc27d8dd025c7d35d69d4cd5609 /meta-python
parent26423c6b6597c449fb5535627bb8344cb4ad24b8 (diff)
downloadmeta-openembedded-b00888a0a6bd5e7ea3c648dd12d1836196e66a6f.tar.gz
python-spidev: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-spidev.inc17
-rw-r--r--meta-python/recipes-devtools/python/python3-spidev_3.2.bb18
2 files changed, 16 insertions, 19 deletions
diff --git a/meta-python/recipes-devtools/python/python-spidev.inc b/meta-python/recipes-devtools/python/python-spidev.inc
deleted file mode 100644
index 1b93763d5..000000000
--- a/meta-python/recipes-devtools/python/python-spidev.inc
+++ /dev/null
@@ -1,17 +0,0 @@
1SUMMARY = "Python bindings for Linux SPI access through spidev"
2DESCRIPTION = "This project contains a python module for interfacing with SPI\
3devices from user space via the spidev linux kernel driver.\
4This is a modified version of the code originally found\
5[here](http://elk.informatik.fh-augsburg.de/da/da-49/trees/pyap7k/lang/py-spi)\
6All code is GPLv2 licensed unless explicitly stated otherwise."
7HOMEPAGE = "http://github.com/doceme/py-spidev"
8SECTION = "devel/python"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://LICENSE.md;md5=54bdb9022ebb75ab68399cdaab97da60"
11SRCNAME = "spidev"
12
13SRC_URI[md5sum] = "f601676f1bb48b9aa3b3897f95216365"
14SRC_URI[sha256sum] = "09d2b5122f0dd79910713a11f9a0020f71537224bf829916def4fffc0ea59456"
15
16
17inherit pypi
diff --git a/meta-python/recipes-devtools/python/python3-spidev_3.2.bb b/meta-python/recipes-devtools/python/python3-spidev_3.2.bb
index 610611e43..65679594d 100644
--- a/meta-python/recipes-devtools/python/python3-spidev_3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-spidev_3.2.bb
@@ -1,2 +1,16 @@
1inherit setuptools3 1SUMMARY = "Python bindings for Linux SPI access through spidev"
2require python-spidev.inc 2DESCRIPTION = "This project contains a python module for interfacing with SPI\
3devices from user space via the spidev linux kernel driver.\
4This is a modified version of the code originally found\
5[here](http://elk.informatik.fh-augsburg.de/da/da-49/trees/pyap7k/lang/py-spi)\
6All code is GPLv2 licensed unless explicitly stated otherwise."
7HOMEPAGE = "http://github.com/doceme/py-spidev"
8SECTION = "devel/python"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://LICENSE.md;md5=54bdb9022ebb75ab68399cdaab97da60"
11SRCNAME = "spidev"
12
13SRC_URI[md5sum] = "f601676f1bb48b9aa3b3897f95216365"
14SRC_URI[sha256sum] = "09d2b5122f0dd79910713a11f9a0020f71537224bf829916def4fffc0ea59456"
15
16inherit pypi setuptools3