summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-12 13:27:24 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:32:07 -0700
commitaafa886ed1ecaa34b240696c06a0e8488054c741 (patch)
tree9ec99d7550500960c66b38a5e755c3611a0f1172 /meta-python
parent1d0f8442f50ea11daa5bd91e9f785411db248593 (diff)
downloadmeta-openembedded-aafa886ed1ecaa34b240696c06a0e8488054c741.tar.gz
python3-rsa: Upgrade 3.4.2 -> 4.6
Upgrade to release 4.6: - Rolled back the switch to Poetry, and reverted back to using Pipenv + setup.py for dependency management. There apparently is an issue no-binary installs of packages build with Poetry. - Limited SHA3 support to those Python versions (3.6+) that support it natively. The third-party library that adds support for this to Python 3.5 is a binary package, and thus breaks the pure-Python nature of Python-RSA. - To avoid older Python installations from trying to upgrade to RSA 4.4, this is now made explicit in the python_requires argument in setup.py The encrypt/decrypt-bigfile CLI commands have been removed in 2016 therefore the recipe has been updated accordingly. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-rsa_4.6.bb (renamed from meta-python/recipes-devtools/python/python3-rsa_3.4.2.bb)7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-rsa_3.4.2.bb b/meta-python/recipes-devtools/python/python3-rsa_4.6.bb
index 759214fa3..d2b108635 100644
--- a/meta-python/recipes-devtools/python/python3-rsa_3.4.2.bb
+++ b/meta-python/recipes-devtools/python/python3-rsa_4.6.bb
@@ -4,15 +4,14 @@ AUTHOR = "Sybren A. Stuvel"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c403f6882d4f97a9cd927df987d55634" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=c403f6882d4f97a9cd927df987d55634"
6 6
7SRC_URI[sha256sum] = "25df4e10c263fb88b5ace923dd84bf9aa7f5019687b5e55382ffcdb8bede9db5" 7SRC_URI[md5sum] = "bbf1c954865319bd542600ab07f92aca"
8SRC_URI[sha256sum] = "109ea5a66744dd859bf16fe904b8d8b627adafb9408753161e766a92e7d681fa"
8 9
9inherit pypi setuptools3 update-alternatives 10inherit pypi setuptools3 update-alternatives
10 11
11ALTERNATIVE_${PN} = "\ 12ALTERNATIVE_${PN} = "\
12 pyrsa-decrypt \ 13 pyrsa-decrypt \
13 pyrsa-decrypt-bigfile \
14 pyrsa-encrypt \ 14 pyrsa-encrypt \
15 pyrsa-encrypt-bigfile \
16 pyrsa-keygen \ 15 pyrsa-keygen \
17 pyrsa-priv2pub \ 16 pyrsa-priv2pub \
18 pyrsa-sign \ 17 pyrsa-sign \
@@ -20,9 +19,7 @@ ALTERNATIVE_${PN} = "\
20" 19"
21 20
22ALTERNATIVE_LINK_NAME[pyrsa-decrypt] = "${bindir}/pyrsa-decrypt" 21ALTERNATIVE_LINK_NAME[pyrsa-decrypt] = "${bindir}/pyrsa-decrypt"
23ALTERNATIVE_LINK_NAME[pyrsa-decrypt-bigfile] = "${bindir}/pyrsa-decrypt-bigfile"
24ALTERNATIVE_LINK_NAME[pyrsa-encrypt] = "${bindir}/pyrsa-encrypt" 22ALTERNATIVE_LINK_NAME[pyrsa-encrypt] = "${bindir}/pyrsa-encrypt"
25ALTERNATIVE_LINK_NAME[pyrsa-encrypt-bigfile] = "${bindir}/pyrsa-encrypt-bigfile"
26ALTERNATIVE_LINK_NAME[pyrsa-keygen] = "${bindir}/pyrsa-keygen" 23ALTERNATIVE_LINK_NAME[pyrsa-keygen] = "${bindir}/pyrsa-keygen"
27ALTERNATIVE_LINK_NAME[pyrsa-priv2pub] = "${bindir}/pyrsa-priv2pub" 24ALTERNATIVE_LINK_NAME[pyrsa-priv2pub] = "${bindir}/pyrsa-priv2pub"
28ALTERNATIVE_LINK_NAME[pyrsa-sign] = "${bindir}/pyrsa-sign" 25ALTERNATIVE_LINK_NAME[pyrsa-sign] = "${bindir}/pyrsa-sign"