summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:12:39 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commitaaaec25c502bacc4df909e983aba5babf92dc1b2 (patch)
tree7c7a3814f287d72246a886571857a3fb6b201d9b /meta-python
parent3f883a745b4b5212869057e278c8820d1d1711c7 (diff)
downloadmeta-openembedded-aaaec25c502bacc4df909e983aba5babf92dc1b2.tar.gz
python-smbus: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-smbus.inc12
-rw-r--r--meta-python/recipes-devtools/python/python3-smbus_4.1.bb13
2 files changed, 12 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python-smbus.inc b/meta-python/recipes-devtools/python/python-smbus.inc
deleted file mode 100644
index 8ba1ab2b8..000000000
--- a/meta-python/recipes-devtools/python/python-smbus.inc
+++ /dev/null
@@ -1,12 +0,0 @@
1SUMMARY = "Set of i2c tools for linux - Python module"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://smbusmodule.c;beginline=1;endline=18;md5=46e424fb045901ab25e0f92c28c80055"
4PR = "r1"
5
6SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/i2c-tools-${PV}.tar.gz "
7SRC_URI[md5sum] = "3536237a6b51fb10caacdc3b8a496237"
8SRC_URI[sha256sum] = "ef8f77afc70e7dbfd1171bfeae87a8a7f10074829370ce8d9ccd585a014e0073"
9
10DEPENDS += "i2c-tools"
11
12S = "${WORKDIR}/i2c-tools-${PV}/py-smbus/"
diff --git a/meta-python/recipes-devtools/python/python3-smbus_4.1.bb b/meta-python/recipes-devtools/python/python3-smbus_4.1.bb
index b357bcd82..1be77393b 100644
--- a/meta-python/recipes-devtools/python/python3-smbus_4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-smbus_4.1.bb
@@ -1,2 +1,13 @@
1SUMMARY = "Set of i2c tools for linux - Python module"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://smbusmodule.c;beginline=1;endline=18;md5=46e424fb045901ab25e0f92c28c80055"
4PR = "r1"
5
6SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/i2c-tools-${PV}.tar.gz "
7SRC_URI[md5sum] = "3536237a6b51fb10caacdc3b8a496237"
8SRC_URI[sha256sum] = "ef8f77afc70e7dbfd1171bfeae87a8a7f10074829370ce8d9ccd585a014e0073"
9
10DEPENDS += "i2c-tools"
11
12S = "${WORKDIR}/i2c-tools-${PV}/py-smbus/"
1inherit distutils3 13inherit distutils3
2require python-smbus.inc