summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorAlistair Francis <alistair.francis@wdc.com>2019-09-06 17:03:38 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-07 10:08:45 -0700
commit7a706c066e88beb07e71a66e1987074198c72ae2 (patch)
treeda0490bc77c7267cfc0da2557cfe38b7ff17ad76 /meta-python
parent3bf4c102a27428abde5e11b13ec2c6b5e9d66fad (diff)
downloadmeta-openembedded-7a706c066e88beb07e71a66e1987074198c72ae2.tar.gz
python3-pytest-asyncio: Initial commit of 0.10.0
Signed-off-by: Alistair Francis <alistair.francis@wdc.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-asyncio.inc13
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb2
2 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest-asyncio.inc b/meta-python/recipes-devtools/python/python-pytest-asyncio.inc
new file mode 100644
index 000000000..9132c7452
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pytest-asyncio.inc
@@ -0,0 +1,13 @@
1DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python, for testing asyncio code with pytest"
2HOMEPAGE = "https://github.com/pytest-dev/pytest-asyncio"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://README.rst;md5=ae62268d207c73b615fbefddaf91a881"
5
6SRC_URI[md5sum] = "247a7ec32f24a185341327c42a0f85bf"
7SRC_URI[sha256sum] = "9fac5100fd716cbecf6ef89233e8590a4ad61d729d1732e0a96b84182df1daaf"
8
9inherit pypi
10
11DEPENDS += "${PYTHON_PN}-pytest-native"
12
13BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
new file mode 100644
index 000000000..09f26f8d1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-pytest-asyncio.inc