summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-07-23 22:25:20 +0800
committerKhem Raj <raj.khem@gmail.com>2021-07-27 09:51:35 -0700
commit75286b2592ff07aa84b1ae992b361c8dc36f5e93 (patch)
treec19789151566f39b4b53a8b47ef148852881971c /meta-python
parent9ada4ac6103c522da419f56a8152900ac647bad1 (diff)
downloadmeta-openembedded-75286b2592ff07aa84b1ae992b361c8dc36f5e93.tar.gz
python3-rdflib: upgrade 5.0.0 -> 6.0.0
-License-Update: Copyright year updated to 2021. 2021/07/20 RELEASE 6.0.0 ======================== 6.0.0 is a major stable release that drops support for Python 2 and Python 3 < 3.7. Type hinting is now present in much of the toolkit as a result. It includes the formerly independent JSON-LD parser/serializer, improvements to Namespaces that allow for IDE namespace prompting, simplified use of `g.serialize()` (turtle default, no need to `decode()`) and many other updates to documentation, store backends and so on. Performance of the in-memory store has also improved since Python 3.6 dictionary improvements. There are numerous supplementary improvements to the toolkit too, such as: * inclusion of Docker files for easier CI/CD * black config files for standardised code formatting * improved testing with mock SPARQL stores, rather than a reliance on DBPedia etc Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-rdflib_5.0.0.bb15
-rw-r--r--meta-python/recipes-devtools/python/python3-rdflib_6.0.0.bb17
2 files changed, 17 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python3-rdflib_5.0.0.bb b/meta-python/recipes-devtools/python/python3-rdflib_5.0.0.bb
deleted file mode 100644
index d037a74bf..000000000
--- a/meta-python/recipes-devtools/python/python3-rdflib_5.0.0.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1SUMMARY = "RDFLib is a pure Python package for working with RDF"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=68c1a3bb687bd63b8e5552f3ea249840"
4
5SRC_URI[md5sum] = "80d7c6adc2e4040cdd8dade2e0e61403"
6SRC_URI[sha256sum] = "78149dd49d385efec3b3adfbd61c87afaf1281c30d3fcaf1b323b34f603fb155"
7
8inherit pypi setuptools3
9
10RDEPENDS_${PN} += " \
11 ${PYTHON_PN}-isodate \
12 ${PYTHON_PN}-pyparsing \
13"
14
15BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-rdflib_6.0.0.bb b/meta-python/recipes-devtools/python/python3-rdflib_6.0.0.bb
new file mode 100644
index 000000000..47cdc49d9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-rdflib_6.0.0.bb
@@ -0,0 +1,17 @@
1SUMMARY = "RDFLib is a pure Python package for working with RDF"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=89aa9a14f80a6ac70e1d5da763a309ed"
4
5SRC_URI[sha256sum] = "7ce4d757eb26f4dd43205ec340d8c097f29e5adfe45d6ea20238c731dc679879"
6
7inherit pypi setuptools3
8
9RDEPENDS_${PN} += " \
10 ${PYTHON_PN}-isodate \
11 ${PYTHON_PN}-pyparsing \
12 ${PYTHON_PN}-logging \
13 ${PYTHON_PN}-numbers \
14 ${PYTHON_PN}-xml \
15"
16
17BBCLASSEXTEND = "native nativesdk"