summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 14:20:58 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:14 -0700
commit66a864ed0d3b730af1bd345dacbd1acf996bbad7 (patch)
treef613c54a092d41eaa4b0d48b6e9a0626ca363cf3 /meta-python
parent055eb129964f2612fbdf16376ef47358e2821e33 (diff)
downloadmeta-openembedded-66a864ed0d3b730af1bd345dacbd1acf996bbad7.tar.gz
python-pyusb: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyusb.inc12
-rw-r--r--meta-python/recipes-devtools/python/python3-pyusb_1.0.2.bb14
2 files changed, 12 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyusb.inc b/meta-python/recipes-devtools/python/python-pyusb.inc
deleted file mode 100644
index e783dd432..000000000
--- a/meta-python/recipes-devtools/python/python-pyusb.inc
+++ /dev/null
@@ -1,12 +0,0 @@
1SUMMARY = "PyUSB provides USB access on the Python language"
2HOMEPAGE = "http://pyusb.sourceforge.net/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=51691ed11cc2c7ae93e383f60ed49b0f"
5DEPENDS += "libusb1"
6
7SRC_URI[md5sum] = "862b56452c64948c787ad8ef9498590b"
8SRC_URI[sha256sum] = "4e9b72cc4a4205ca64fbf1f3fff39a335512166c151ad103e55c8223ac147362"
9
10inherit pypi
11
12BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pyusb_1.0.2.bb b/meta-python/recipes-devtools/python/python3-pyusb_1.0.2.bb
index 1ecede7cf..44c24f423 100644
--- a/meta-python/recipes-devtools/python/python3-pyusb_1.0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pyusb_1.0.2.bb
@@ -1,2 +1,12 @@
1inherit setuptools3 1SUMMARY = "PyUSB provides USB access on the Python language"
2require python-pyusb.inc 2HOMEPAGE = "http://pyusb.sourceforge.net/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=51691ed11cc2c7ae93e383f60ed49b0f"
5DEPENDS += "libusb1"
6
7SRC_URI[md5sum] = "862b56452c64948c787ad8ef9498590b"
8SRC_URI[sha256sum] = "4e9b72cc4a4205ca64fbf1f3fff39a335512166c151ad103e55c8223ac147362"
9
10inherit pypi setuptools3
11
12BBCLASSEXTEND = "native nativesdk"