summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-05 12:41:58 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:14 -0700
commit66080b798f043dcd03b92f2c34074068bf4f6d4b (patch)
treed96e492bfb8182e169e0d77277fd6278457b8d5b /meta-python
parentf4f4b23d46518e3215fd12410b295cf8143f7191 (diff)
downloadmeta-openembedded-66080b798f043dcd03b92f2c34074068bf4f6d4b.tar.gz
python-pyperclip: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyperclip.inc14
-rw-r--r--meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb16
2 files changed, 14 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyperclip.inc b/meta-python/recipes-devtools/python/python-pyperclip.inc
deleted file mode 100644
index 85a4312c2..000000000
--- a/meta-python/recipes-devtools/python/python-pyperclip.inc
+++ /dev/null
@@ -1,14 +0,0 @@
1DESCRIPTION = "A cross-platform clipboard module for Python. (only handles plain text for now)"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a428356ada7737b416ec4b63dc65d581"
4
5SRC_URI[md5sum] = "6bbb8598579cc3ee50554b4c59d0cfae"
6SRC_URI[sha256sum] = "979325468ccf682104d5dcaf753f869868100631301d3e72f47babdea5700d1c"
7
8inherit pypi
9
10RDEPENDS_${PN} += " \
11 ${PYTHON_PN}-ctypes \
12"
13
14BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb b/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb
index ee6f88bbb..52d109abc 100644
--- a/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb
@@ -1,2 +1,14 @@
1inherit setuptools3 1DESCRIPTION = "A cross-platform clipboard module for Python. (only handles plain text for now)"
2require python-pyperclip.inc 2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a428356ada7737b416ec4b63dc65d581"
4
5SRC_URI[md5sum] = "6bbb8598579cc3ee50554b4c59d0cfae"
6SRC_URI[sha256sum] = "979325468ccf682104d5dcaf753f869868100631301d3e72f47babdea5700d1c"
7
8inherit pypi setuptools3
9
10RDEPENDS_${PN} += " \
11 ${PYTHON_PN}-ctypes \
12"
13
14BBCLASSEXTEND = "native nativesdk"