diff options
author | Derek Straka <derek@asterius.io> | 2020-04-05 12:41:58 -0400 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-04-05 10:38:14 -0700 |
commit | 66080b798f043dcd03b92f2c34074068bf4f6d4b (patch) | |
tree | d96e492bfb8182e169e0d77277fd6278457b8d5b /meta-python | |
parent | f4f4b23d46518e3215fd12410b295cf8143f7191 (diff) | |
download | meta-openembedded-66080b798f043dcd03b92f2c34074068bf4f6d4b.tar.gz |
python-pyperclip: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pyperclip.inc | 14 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb | 16 |
2 files changed, 14 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyperclip.inc b/meta-python/recipes-devtools/python/python-pyperclip.inc deleted file mode 100644 index 85a4312c2..000000000 --- a/meta-python/recipes-devtools/python/python-pyperclip.inc +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | DESCRIPTION = "A cross-platform clipboard module for Python. (only handles plain text for now)" | ||
2 | LICENSE = "BSD" | ||
3 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a428356ada7737b416ec4b63dc65d581" | ||
4 | |||
5 | SRC_URI[md5sum] = "6bbb8598579cc3ee50554b4c59d0cfae" | ||
6 | SRC_URI[sha256sum] = "979325468ccf682104d5dcaf753f869868100631301d3e72f47babdea5700d1c" | ||
7 | |||
8 | inherit pypi | ||
9 | |||
10 | RDEPENDS_${PN} += " \ | ||
11 | ${PYTHON_PN}-ctypes \ | ||
12 | " | ||
13 | |||
14 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb b/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb index ee6f88bbb..52d109abc 100644 --- a/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb +++ b/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb | |||
@@ -1,2 +1,14 @@ | |||
1 | inherit setuptools3 | 1 | DESCRIPTION = "A cross-platform clipboard module for Python. (only handles plain text for now)" |
2 | require python-pyperclip.inc | 2 | LICENSE = "BSD" |
3 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a428356ada7737b416ec4b63dc65d581" | ||
4 | |||
5 | SRC_URI[md5sum] = "6bbb8598579cc3ee50554b4c59d0cfae" | ||
6 | SRC_URI[sha256sum] = "979325468ccf682104d5dcaf753f869868100631301d3e72f47babdea5700d1c" | ||
7 | |||
8 | inherit pypi setuptools3 | ||
9 | |||
10 | RDEPENDS_${PN} += " \ | ||
11 | ${PYTHON_PN}-ctypes \ | ||
12 | " | ||
13 | |||
14 | BBCLASSEXTEND = "native nativesdk" | ||