diff options
author | Derek Straka <derek@asterius.io> | 2020-04-04 13:12:45 -0400 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-04-05 10:38:13 -0700 |
commit | 5c9d583d6d764a68f3174f62e3838318568ea418 (patch) | |
tree | e1cee06cb6b677e5f54289779b912109e7493134 /meta-python | |
parent | de9c7c23c80718e73275a2410821c0047ad4d937 (diff) | |
download | meta-openembedded-5c9d583d6d764a68f3174f62e3838318568ea418.tar.gz |
python-sh: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-sh.inc | 32 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-sh_1.12.14.bb | 23 |
2 files changed, 21 insertions, 34 deletions
diff --git a/meta-python/recipes-devtools/python/python-sh.inc b/meta-python/recipes-devtools/python/python-sh.inc deleted file mode 100644 index f2fd562bb..000000000 --- a/meta-python/recipes-devtools/python/python-sh.inc +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | SUMMARY = "Python subprocess replacement" | ||
2 | HOMEPAGE = "https://github.com/amoffat/sh" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5317094292296f03405f59ae5f6544b6" | ||
5 | |||
6 | SRC_URI[md5sum] = "a8351aef25d25f707c17e0a7a6280251" | ||
7 | SRC_URI[sha256sum] = "b52bf5833ed01c7b5c5fb73a7f71b3d98d48e9b9b8764236237bdc7ecae850fc" | ||
8 | |||
9 | PYPI_PACKAGE = "sh" | ||
10 | |||
11 | inherit pypi | ||
12 | |||
13 | RDEPENDS_${PN} += " \ | ||
14 | ${PYTHON_PN}-codecs \ | ||
15 | ${PYTHON_PN}-core \ | ||
16 | ${PYTHON_PN}-io \ | ||
17 | ${PYTHON_PN}-logging \ | ||
18 | ${PYTHON_PN}-resource \ | ||
19 | ${PYTHON_PN}-shell \ | ||
20 | ${PYTHON_PN}-terminal \ | ||
21 | ${PYTHON_PN}-tests \ | ||
22 | ${PYTHON_PN}-threading \ | ||
23 | ${PYTHON_PN}-unixadmin \ | ||
24 | " | ||
25 | |||
26 | # WARNING: We were unable to map the following python package/module | ||
27 | # dependencies to the bitbake packages which include them: | ||
28 | # coverage - only used in test and there is a check to see if it is | ||
29 | # available before importing. | ||
30 | # queue - part of threading | ||
31 | # signal - part of core in python3. not sure how it is imported in python2. | ||
32 | # No complants in compiling. | ||
diff --git a/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb b/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb index 812bd4b1a..b7858734b 100644 --- a/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb +++ b/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb | |||
@@ -1,5 +1,24 @@ | |||
1 | require python-sh.inc | 1 | SUMMARY = "Python subprocess replacement" |
2 | inherit setuptools3 | 2 | HOMEPAGE = "https://github.com/amoffat/sh" |
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5317094292296f03405f59ae5f6544b6" | ||
5 | |||
6 | SRC_URI[md5sum] = "a8351aef25d25f707c17e0a7a6280251" | ||
7 | SRC_URI[sha256sum] = "b52bf5833ed01c7b5c5fb73a7f71b3d98d48e9b9b8764236237bdc7ecae850fc" | ||
8 | |||
9 | PYPI_PACKAGE = "sh" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
3 | 12 | ||
4 | RDEPENDS_${PN} += " \ | 13 | RDEPENDS_${PN} += " \ |
14 | ${PYTHON_PN}-codecs \ | ||
15 | ${PYTHON_PN}-core \ | ||
16 | ${PYTHON_PN}-io \ | ||
17 | ${PYTHON_PN}-logging \ | ||
18 | ${PYTHON_PN}-resource \ | ||
19 | ${PYTHON_PN}-shell \ | ||
20 | ${PYTHON_PN}-terminal \ | ||
21 | ${PYTHON_PN}-tests \ | ||
22 | ${PYTHON_PN}-threading \ | ||
23 | ${PYTHON_PN}-unixadmin \ | ||
5 | " | 24 | " |