summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:12:34 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commit41e4d12b90545407f6141d8483164401f6274ce6 (patch)
tree977aafb1a1f1470560e1ba325e85c4c6f0a5be5e /meta-python
parent4ecf8c7780105f155800098de7418c6ee47be388 (diff)
downloadmeta-openembedded-41e4d12b90545407f6141d8483164401f6274ce6.tar.gz
python-sqlparse: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-sqlparse.inc27
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb30
2 files changed, 28 insertions, 29 deletions
diff --git a/meta-python/recipes-devtools/python/python-sqlparse.inc b/meta-python/recipes-devtools/python/python-sqlparse.inc
deleted file mode 100644
index 45a1e5677..000000000
--- a/meta-python/recipes-devtools/python/python-sqlparse.inc
+++ /dev/null
@@ -1,27 +0,0 @@
1DESCRIPTION = "Non-validating SQL parser module"
2HOMEPAGE = "http://pypi.python.org/pypi/sqlparse"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc"
6
7SRC_URI += "file://0001-sqlparse-change-shebang-to-python3.patch \
8 file://run-ptest \
9 "
10
11SRC_URI[md5sum] = "423047887a3590b04dd18f8caf843a2f"
12SRC_URI[sha256sum] = "e162203737712307dfe78860cc56c8da8a852ab2ee33750e33aeadf38d12c548"
13
14export BUILD_SYS
15export HOST_SYS
16
17inherit pypi ptest
18
19RDEPENDS_${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21 ${PYTHON_PN}-unixadmin \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
diff --git a/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb b/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb
index a646ac648..1aef28be0 100644
--- a/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb
@@ -1,3 +1,29 @@
1inherit setuptools3 1DESCRIPTION = "Non-validating SQL parser module"
2require python-sqlparse.inc 2HOMEPAGE = "http://pypi.python.org/pypi/sqlparse"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc"
6
7SRC_URI += "file://0001-sqlparse-change-shebang-to-python3.patch \
8 file://run-ptest \
9 "
10
11SRC_URI[md5sum] = "423047887a3590b04dd18f8caf843a2f"
12SRC_URI[sha256sum] = "e162203737712307dfe78860cc56c8da8a852ab2ee33750e33aeadf38d12c548"
13
14export BUILD_SYS
15export HOST_SYS
16
17inherit pypi ptest setuptools3
18
19RDEPENDS_${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21 ${PYTHON_PN}-unixadmin \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
28
3BBCLASSEXTEND = "native nativesdk" 29BBCLASSEXTEND = "native nativesdk"