diff options
author | Tim Orling <ticotimo@gmail.com> | 2020-04-25 23:48:02 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-04-26 23:12:21 -0700 |
commit | 20d70c1310cce89fe3a7025eae2eb03dca5459bd (patch) | |
tree | 4cd6ec2bee9de97f075b1f20e7b331164156db8e /meta-python | |
parent | fba5d0ae98b63109b6602862f4480f7c582387b3 (diff) | |
download | meta-openembedded-20d70c1310cce89fe3a7025eae2eb03dca5459bd.tar.gz |
python3-cryptography: merge bb and inc
Drop python-cryptography/ not used anywhere.
Signed-off-by: Tim Orling <ticotimo@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 59 insertions, 62 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography.inc b/meta-python/recipes-devtools/python/python-cryptography.inc deleted file mode 100644 index 5acd02d67..000000000 --- a/meta-python/recipes-devtools/python/python-cryptography.inc +++ /dev/null | |||
@@ -1,58 +0,0 @@ | |||
1 | SUMMARY = "Provides cryptographic recipes and primitives to python developers" | ||
2 | HOMEPAGE = "https://cryptography.io/" | ||
3 | LICENSE = "Apache-2.0 | BSD" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=097f805837700cfac572ac274cd38124" | ||
5 | |||
6 | LDSHARED += "-pthread" | ||
7 | |||
8 | DEPENDS += " \ | ||
9 | ${PYTHON_PN}-cffi \ | ||
10 | ${PYTHON_PN}-cffi-native \ | ||
11 | ${PYTHON_PN}-asn1crypto \ | ||
12 | ${PYTHON_PN}-six \ | ||
13 | " | ||
14 | |||
15 | SRC_URI[md5sum] = "77730058b556c6d9838679a94c6229ce" | ||
16 | SRC_URI[sha256sum] = "3cda1f0ed8747339bbdf71b9f38ca74c7b592f24f65cdb3ab3765e4b02871651" | ||
17 | |||
18 | RDEPENDS_${PN} += " \ | ||
19 | ${PYTHON_PN}-cffi \ | ||
20 | ${PYTHON_PN}-idna \ | ||
21 | ${PYTHON_PN}-asn1crypto \ | ||
22 | ${PYTHON_PN}-setuptools \ | ||
23 | ${PYTHON_PN}-six \ | ||
24 | " | ||
25 | |||
26 | RDEPENDS_${PN}_class-target += " \ | ||
27 | ${PYTHON_PN}-cffi \ | ||
28 | ${PYTHON_PN}-idna \ | ||
29 | ${PYTHON_PN}-numbers \ | ||
30 | ${PYTHON_PN}-asn1crypto \ | ||
31 | ${PYTHON_PN}-setuptools \ | ||
32 | ${PYTHON_PN}-six \ | ||
33 | ${PYTHON_PN}-threading \ | ||
34 | " | ||
35 | |||
36 | RDEPENDS_${PN}-ptest += " \ | ||
37 | ${PN} \ | ||
38 | ${PYTHON_PN}-cryptography-vectors \ | ||
39 | ${PYTHON_PN}-iso8601 \ | ||
40 | ${PYTHON_PN}-pretend \ | ||
41 | ${PYTHON_PN}-pytest \ | ||
42 | ${PYTHON_PN}-pytz \ | ||
43 | " | ||
44 | |||
45 | inherit ptest | ||
46 | |||
47 | do_install_ptest() { | ||
48 | install -d ${D}${PTEST_PATH}/tests | ||
49 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
50 | install -d ${D}${PTEST_PATH}/tests/hazmat | ||
51 | cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/ | ||
52 | } | ||
53 | |||
54 | FILES_${PN}-dbg += " \ | ||
55 | ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \ | ||
56 | " | ||
57 | |||
58 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python-cryptography/run-ptest b/meta-python/recipes-devtools/python/python-cryptography/run-ptest deleted file mode 100644 index 0ba239c2a..000000000 --- a/meta-python/recipes-devtools/python/python-cryptography/run-ptest +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | py.test | ||
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb b/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb index 195923343..c75dabb97 100644 --- a/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb +++ b/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb | |||
@@ -1,8 +1,65 @@ | |||
1 | inherit pypi setuptools3 | 1 | SUMMARY = "Provides cryptographic recipes and primitives to python developers" |
2 | require python-cryptography.inc | 2 | HOMEPAGE = "https://cryptography.io/" |
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0 | BSD" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=097f805837700cfac572ac274cd38124" | ||
3 | 6 | ||
4 | LDSHARED += "-pthread" | 7 | LDSHARED += "-pthread" |
5 | 8 | ||
9 | SRC_URI[md5sum] = "77730058b556c6d9838679a94c6229ce" | ||
10 | SRC_URI[sha256sum] = "3cda1f0ed8747339bbdf71b9f38ca74c7b592f24f65cdb3ab3765e4b02871651" | ||
11 | |||
6 | SRC_URI += " \ | 12 | SRC_URI += " \ |
7 | file://run-ptest \ | 13 | file://run-ptest \ |
8 | " | 14 | " |
15 | |||
16 | inherit pypi setuptools3 | ||
17 | |||
18 | DEPENDS += " \ | ||
19 | ${PYTHON_PN}-cffi \ | ||
20 | ${PYTHON_PN}-cffi-native \ | ||
21 | ${PYTHON_PN}-asn1crypto \ | ||
22 | ${PYTHON_PN}-six \ | ||
23 | " | ||
24 | |||
25 | RDEPENDS_${PN} += " \ | ||
26 | ${PYTHON_PN}-cffi \ | ||
27 | ${PYTHON_PN}-idna \ | ||
28 | ${PYTHON_PN}-asn1crypto \ | ||
29 | ${PYTHON_PN}-setuptools \ | ||
30 | ${PYTHON_PN}-six \ | ||
31 | " | ||
32 | |||
33 | RDEPENDS_${PN}_class-target += " \ | ||
34 | ${PYTHON_PN}-cffi \ | ||
35 | ${PYTHON_PN}-idna \ | ||
36 | ${PYTHON_PN}-numbers \ | ||
37 | ${PYTHON_PN}-asn1crypto \ | ||
38 | ${PYTHON_PN}-setuptools \ | ||
39 | ${PYTHON_PN}-six \ | ||
40 | ${PYTHON_PN}-threading \ | ||
41 | " | ||
42 | |||
43 | RDEPENDS_${PN}-ptest += " \ | ||
44 | ${PN} \ | ||
45 | ${PYTHON_PN}-cryptography-vectors \ | ||
46 | ${PYTHON_PN}-iso8601 \ | ||
47 | ${PYTHON_PN}-pretend \ | ||
48 | ${PYTHON_PN}-pytest \ | ||
49 | ${PYTHON_PN}-pytz \ | ||
50 | " | ||
51 | |||
52 | inherit ptest | ||
53 | |||
54 | do_install_ptest() { | ||
55 | install -d ${D}${PTEST_PATH}/tests | ||
56 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
57 | install -d ${D}${PTEST_PATH}/tests/hazmat | ||
58 | cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/ | ||
59 | } | ||
60 | |||
61 | FILES_${PN}-dbg += " \ | ||
62 | ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \ | ||
63 | " | ||
64 | |||
65 | BBCLASSEXTEND = "native nativesdk" | ||