diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2017-08-24 10:59:24 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-28 11:06:05 +0200 |
commit | 12e866c2cbbd2227cc6097400a10abfcdb5bb47a (patch) | |
tree | 4ff9959668d086b40881cd8874f250bbd0f41030 /meta-python | |
parent | 4d71753da9d11bf96e3d46cc74735188c3a7d7a2 (diff) | |
download | meta-openembedded-12e866c2cbbd2227cc6097400a10abfcdb5bb47a.tar.gz |
python*-pylint: upgrade to v1.7.2 and fix qa error
Fix file-rdeps error about "#!/usr/bin/python" in python3-pylint
by inheriting python*-dir so we can change to "#!/usr/bin/env ${PYTHON_PN}"
in ${PYTHON_SITEPACKAGES_DIR}.
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pylint.inc | 5 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-pylint_1.7.2.bb (renamed from meta-python/recipes-devtools/python/python-pylint_1.6.5.bb) | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pylint_1.7.2.bb | 2 |
4 files changed, 6 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-pylint.inc b/meta-python/recipes-devtools/python/python-pylint.inc index 18be8a191..3ce1cae21 100644 --- a/meta-python/recipes-devtools/python/python-pylint.inc +++ b/meta-python/recipes-devtools/python/python-pylint.inc | |||
@@ -3,8 +3,8 @@ HOMEPAGE= "http://www.pylint.org/" | |||
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" |
5 | 5 | ||
6 | SRC_URI[md5sum] = "31da2185bf59142479e4fa16d8a9e347" | 6 | SRC_URI[md5sum] = "27ee752cdcfacb05bf4940947e6b35c6" |
7 | SRC_URI[sha256sum] = "a673984a8dd78e4a8b8cfdee5359a1309d833cf38405008f4a249994a8456719" | 7 | SRC_URI[sha256sum] = "ea6afb93a9ed810cf52ff3838eb3a15e2bf6a81b80de0eaede1ce442caa5ca69" |
8 | 8 | ||
9 | inherit pypi | 9 | inherit pypi |
10 | 10 | ||
@@ -28,4 +28,5 @@ from pylint import run_pylint | |||
28 | run_pylint() | 28 | run_pylint() |
29 | EOF | 29 | EOF |
30 | chmod 755 ${D}${bindir}/pylint | 30 | chmod 755 ${D}${bindir}/pylint |
31 | sed -i -e 's:^#!/usr/bin/python:#!/usr/bin/env\ ${PYTHON_PN}:g' ${D}/${PYTHON_SITEPACKAGES_DIR}/pylint/test/data/ascript | ||
31 | } | 32 | } |
diff --git a/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb b/meta-python/recipes-devtools/python/python-pylint_1.7.2.bb index 47ab36a3b..7b51d3fbd 100644 --- a/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb +++ b/meta-python/recipes-devtools/python/python-pylint_1.7.2.bb | |||
@@ -1,4 +1,4 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools python-dir |
2 | require python-pylint.inc | 2 | require python-pylint.inc |
3 | 3 | ||
4 | RDEPENDS_${PN} += "${PYTHON_PN}-backports-functools-lru-cache" | 4 | RDEPENDS_${PN} += "${PYTHON_PN}-backports-functools-lru-cache" |
diff --git a/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb b/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb deleted file mode 100644 index fed65b303..000000000 --- a/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-pylint.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-pylint_1.7.2.bb b/meta-python/recipes-devtools/python/python3-pylint_1.7.2.bb new file mode 100644 index 000000000..563e8316c --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pylint_1.7.2.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 python3-dir | ||
2 | require python-pylint.inc | ||