summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2021-07-16 09:27:37 -0400
committerKhem Raj <raj.khem@gmail.com>2021-07-20 09:27:56 -0700
commit04701ddaa77e77e64eea29f63e3025e83b95099a (patch)
tree5be2b63067a3549e4370804575f13f6f800dcc46 /meta-python
parentcd80092d94fa65f1a6501b00d9a5e567d9887181 (diff)
downloadmeta-openembedded-04701ddaa77e77e64eea29f63e3025e83b95099a.tar.gz
python3-cassandra-driver: add geomet to RDEPENDS, remove DISTUTILS options
python3-cassandra-driver is failing on do_install because the recipe is trying to pull sources while installing, but it can no longer do this because a recent change to python3-setuptools removing support for the deprecated ssl.match_hostname method. Since this only seems to occur when the DISTUTILS = "--no-libev" option to disable the libev extension is given, remove that from the recipe and let the extension be compiled into the package. Additionally, add python3-geomet (the dependency that cassandra-driver was trying to pull during do_install) to the RDEPENDS now that it exists as a recipe. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-cassandra-driver_3.25.0.bb8
1 files changed, 1 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cassandra-driver_3.25.0.bb b/meta-python/recipes-devtools/python/python3-cassandra-driver_3.25.0.bb
index a1941bf3c..ad446d6ef 100644
--- a/meta-python/recipes-devtools/python/python3-cassandra-driver_3.25.0.bb
+++ b/meta-python/recipes-devtools/python/python3-cassandra-driver_3.25.0.bb
@@ -10,17 +10,11 @@ SRCNAME = "cassandra-driver"
10 10
11SRC_URI[sha256sum] = "8ad7d7c090eb1cac6110b3bfc1fd2d334ac62f415aac09350ebb8d241b7aa7ee" 11SRC_URI[sha256sum] = "8ad7d7c090eb1cac6110b3bfc1fd2d334ac62f415aac09350ebb8d241b7aa7ee"
12 12
13DISTUTILS_BUILD_ARGS += " \
14 --no-libev \
15"
16DISTUTILS_INSTALL_ARGS += " \
17 --no-libev \
18"
19
20inherit pypi setuptools3 13inherit pypi setuptools3
21 14
22RDEPENDS_${PN} += "\ 15RDEPENDS_${PN} += "\
23 ${PYTHON_PN}-cython \ 16 ${PYTHON_PN}-cython \
17 ${PYTHON_PN}-geomet \
24 ${PYTHON_PN}-json \ 18 ${PYTHON_PN}-json \
25 ${PYTHON_PN}-misc \ 19 ${PYTHON_PN}-misc \
26 ${PYTHON_PN}-multiprocessing \ 20 ${PYTHON_PN}-multiprocessing \